Bought 3 strips, 1 added to Homekit without issue, other two wont

Hello, I recently purchased 3 lightstrips.

The first one I set up about 3 weeks back and upon me going into its settings and selecting “Add to Home” (Apple Homekit) it instantly came up with a little popup saying “Yeelight wants to add an Accessory to your home”, I went thorugh the process and it integrated with my Homekit setup easily.

The other two do not, instead the “Add to Home” button just doesn’t do anything, or when it does Homekit requests a code/barcode/manually enter a code. Now the devices have no codes on them anywhere for Homekit, I tried the default code “11122333” but it didn’t work.

It’s weird as the first one didn’t even have a problem, it just added itself fine without issue but the other two aren’t integrating at all. Any ideas?

I have the same issue with the Yeelight Lightstrip Plus, there is no way of adding them to my home (and I have tried A LOT of the suggested solutions on this forum!). Hope there is a solution soon!

Hi, sorry for inconvenient, this issue has been fixed. Please try again.

Do you mean if the light strip is connected to the yeelight app, it is automaticly supposed to be connected to the home app? Because in my case, it isn’t and I have no idea how to add it to the home app. Tried SG and CN server.

Hi, you can follow this video to add your light strip to home app :grinning:

Hi there, I also have the same problem. Yeelight Light Strip 1S. When trying to add to Homekit I’m asked to enter the HomeKit code which doesn’t exist (11122333 doesn’t work either). I’m on the latest firmware, on the same 2.4ghz network, have tried going through both the Yeelight and the Mi Home app, and even tried multiple servers, including mainland China. I simply can’t add it to HomeKit. Is there a fix to this issue?

Seems to be not working still. I am unable to add to HomeKit. I was able to add once, but then it became unresponsive.