Yeelight 2.0.6_0041 LAN Control not working

Hi Guys,

I have 4 Yeelight CT2 (Tune-able white) bulbs on firmware version 2.0.6_0041 and even though I have enabled LAN control in the app I am unable to connect to the bulbs over LAN.

I have tried the following things:

  • Toggling the LAN control option in the Yeelight app.
  • Giving the bulbs static IP’s.
  • Resetting and re-paring the bulbs in the Yeelight app.

Even though my bulbs work fine through the Yeelight app when I try to telnet into the bulbs I get the following message:
telnet: Unable to connect to remote host: No route to host

When I try to ping the bulbs I get this message:
From 192.168.XX.XX icmp_seq=1 Destination Host Unreachable

I can ping other devices on the network fine and I know I have had LAN control working on old firmware in the past.

Any help would be much appreciated, as I would love to buy more of these bulbs if I can resolve this issue. Thanks.

1 Like

Most likely something on your router. I have all types of bulbs and everything works fine. Don’t forget you have to telnet to specific port (cant remember which one right now)

1 Like

Problem Solved

I found the problem was when I was adding the bulbs in the Yeelight app I was selecting “LED Bulb (White)” instead of “LED Bulb (CT)”. Even though the bulbs were working fine in the Yeelight app when set to the wrong device, LAN control couldn’t be enabled properly.

LAN Control is now working :smile:

1 Like