SOLVED: Can't connect to network

UPDATE: Immediately after posting I tried doing the installation with mobile data (4G) turned on, and the setup worked. I have tested it again and can confirm that it was the solution.

The lamp was working properly for a few months, but I reseted it unintentionally and now i can’t connect it again with my router.

My Mi Account ID: 6290308459

So far I have tried:

  1. Connecting it to another phone using a hotspot;
  2. Using another account (ID 2410552805) to try to setup the lamp;
  3. Changing the server to mainland china (and other servers);
  4. Connecting the lamp to a signal repeater;
  5. Disabling 5ghz connection on my router;
  6. Using the Mi Home app and the Yeelight app;
  7. Installing the lamp in other sockets around my home;
  8. Factory reseting the lamp between each attempt.

The setup process goes as follows:

  1. The phone connects to the lamp, and the installation percentage reaches 29% instantly;
  2. The phone disconnects to the lamp and connects to my local network, and the percentage slowly reaches 49%;
  3. After reaching 49%, it displays the error “Device disconnected - Keep phone close to device and try again”.

Same thing happens when using a phone with a hotspot.

Also, the lamp does not appear in the DHCP information in my router.