Connection timed out. Yeelight Smart Light Strips.

For 3 months now I have not been able to connect my two Yeelight Smart Light Strips. I’m from Russia.
First, one tape went offline, then a couple of days later another tape.
Reinstalling Yeelight App with clearing cache and data, changing servers - it’s useless.
After reset, the indicator blinks yellow as expected, I connect through the application, then the blue indicator lights up when connected, i.e. they connect to the wi-fi without problems and the MAC is displayed in the router, but then “Connection timed out”. The configuration does not complete.
I suspect that the router cannot connect to the Mi Cloud server. I have an optical internet of 100 megabits / sec. I contacted those. Provider support, I was advised to contact the developers.
Help me please!

Hello, try change the DNS of your router to Also, if your router support DNS over Http(DoH). Turn it on.

Thank you so much!!! You helped me!!! :partying_face: :partying_face: :partying_face:

Hi, can you tell me how you fixed it? Did you just change the DNS?

Yes, I wrote the DNS in the router settings.
In the DHCP section, I had empty DNS fields.
I entered and there, then pressed the save button.
After another smart light strip reset, I tried to connect and the connection was successful. I also connected the second smart light strip without problems.

Thank you very much for your information. This is very helpful to us. :grinning: