The bulb turns on with too much red sometimes

Hi,

I have 3 1S color bulbs connected in the same place in my room. A month ago one of them started to acting up. When turned on, it was reddish instead of white. The only way to get it to work again was to turn it off and on from the wall switch - cut off the power for a while. I noticed that it mainly happened when the bulb was off (standby powered) for a longer time (around 20hrs). After turning it off and on from the wall switch I could turn it on and off from the app and it was working ok (no reddish color). Finally I decided to replace the bulb with a new one, and for now it is woking ok. The strange thing is that another bulb (one of those 3 but not the new one) started to do the same thing. It turns on with reddish color from time time. The firmware is 2.0.6_0027. Is this a hardware fault or a bug?

2 Likes

I have exactly the same problem. I have several lamps. Two of them are 1s versions. One of these lamps turns red after a while. You have to turn it off and turn it on with the switch. Quite an annoying problem.

I have exactly the same problem. I had 3 1S bulbs and they all had the same issue after around 1 month of use. I returned one of them and yeelight gave me a new bulb but it also had the same issue after 2 weeks of use.

1 Like

Same issue with my 1st 1s bulb… after updating it turns red when the brightness is set to 50% or lower even if you set rhe color to warm. White or orange or sunset… and it has no green color when you set the brightness to 40% or lower… you need to to turn it off and on on the main switch to work again.

1 Like

Same problem here, but after exchange with seller 2 months ago, I got a new bulb with firmware 2.0.6_0025, it just work normally without update, so I was thinking maybe there are some bug with 2.0.6_0027?

Same here. Any workaround?

I have 2 bulbs, the one with no update has no color issues. I think your right that there are bugs with the firmware 2.0.6_0027 bec my bulb with problem are in that firmware…

@chyhaiyuan @yusure can help? Thanks so much

Having the same issue on firmware 2.0.6_0024

Any news on this?
I have to hard power off and on my bulb every day for it to work properly, its very annoying!

1 Like

It’s been 3 months and no answer from yeelight team so far, and no new firmware is available. What should we do?

I have the same problem. It happens with the most used bulbs. I am thinking maybe this it due overhearing?

Initially I had in my living room color bulb 1 after half a year it started to turn redish I switched the bulbs but it happened again. I switched to 1S it worked well a bit but after update it started to show the same problem.

There where an update where they improved luminosity on white light i believe this is the cause but I can’t test it, I don’t know how to downgrade the firmware:(

Is there any news on this issue? Or should I return these bulbs?

I have two bulbs version yeelink.light.color2 with firmware 2.0.6_0065 - they work well. And I have two bulbs version yeelink.light.color4 with firmware 2.0.6_0027 - with them the problem is red when turned on. There is a solution?

I have 2 color2 bulbs on the same firmware and only one of them has this issue. I have chosen to replace the faulty bulb, hopefully the next one is ok.

Hey, please update us on how it goes. If it’s a hardware thing, I will consider returning them too. Yeelight staff is not responding to this issue for so long.

1 Like

I think I have the same problem or at least very similar. I have the light in my living room where it’s on almost all-day (5000K and full brightness) and at night when I set it to warm white and dim it to 50% the color turns red. I suspect it might be a hardware issue, as when I mess with the brightness I can sometimes see the warm white leds flicker a little inside the bulb. On full brightness it works ok.

Yup this is the same issue, clearly it is a common fault.

If you cut the power to the bulb and power back on the issue will be gone, but it will come back within a few hours.

1 Like

Yeah cutting power works for a while. I moved the misbehaving light to my bedroom, as I don’t spend much time there and it worked for a couple days until the issue came back.

Now that I think of it more, maybe it isn’t hardware related after all if power cycling from the wall instantly makes if function correctly. I thought that maybe it’s overheating or something, but clearly that isn’t the case as 1 second being off wouldn’t cool it enough.

1 Like

both my bulbs are doing it now. :confused:

2 Likes