Yeelight Toolbox

I can only use with the notebook connected via wifi, when I am using the network cable, even in the same network, the bulbs are not found. Is there any way to change this? Thanks!

Update: Only the 1st gen bulb are not find thru ethernet cable. All 2nd gen are OK.

Hey! Check out my new app, an improved music mode for android that captures internal audio instead of recording from the microphone.
Download it from Google Play: https://play.google.com/store/apps/details?id=com.jordigordillo.yeelightmusic
More details here: https://thirdparty.yeelight.com/topics/239/music-mode-for-yeelight

I know I haven’t updated Yeelight Toolbox much while working on this, but development will be resumed. Thanks for your patience!

i hope the bulb/device grouping would be one of your priorities in the next release

1 Like

Same ! It would be nice :+1:

Grouping will come next, I know you all want it, but I only have one bulb right now. As soon as I get more hardware, I’ll implement it

2 Likes

v2.0.0 released
· Added a dark theme.
· Reduced movie mode flickering (more improvements to come with a firmware update, which eliminates flickering and provides smoother transitions. It’s currently in beta).
· Performance settings for movie mode in advanced tab.
· Added keyboard shortcuts.
· Added a donation link in about tab.
· Bug fixes for movie mode.
· UI improvements and bug fixes.
· Updated app icon.

Changelog: https://drive.google.com/open?id=1y1G695C1ErY0AD8dOwrLQvG-Y1ZU2Nllp7IMnrSBN00
Download: https://drive.google.com/open?id=1uIRyFDb90kFlALWi6HIMVYjKCdDvgKGy

v2.0.1
· Multi-core movie mode.
· UI improvements.

1 Like

Nice work ! Really appreciate it !

I tried the v2.0.1 and noticed the new (?) dark theme (which is nice IMO).
Just a small thing about it, on the left side, I think that devices addresses should be written in white or grey instead of black for more visibility.

It would be also nice to be able to put a name/tag on devices.
I know that you have only 1 device but for example I have 3 devices (2 bulbs + 1 strip).
I know that when I select a device, at the bottom right part the “device model” is written, but I have actually two similar bulbs so I never know which one is which.
Of course with time I know the order in the list but putting a tag would be awesome.

Can’t wait to be able to make Groups too ! (I’ve read what you said about it a week ago).

Good continuation !

  • Thanks for your suggestion, I’ll change the text color.
  • You can already do that, click where it says “Name: not set” at the bottom, change it to the name you want and press enter to save.
1 Like

Oh sweeeet thank you for the tip ! :wink:
I’ve never noticed that before…

Good thing for the text color thank you :wink:

I’ll change the text to something like “click to change” instead of “not set”

Good idea :+1:

Just updated to the newest version and now i cant find my lightstrips- Tried uninstalling.

Nothing else changed. Try resetting your devices or re enabling lan control

got it working!

v2.0.2
· Minor UI improvements.

1 Like

Thanks for the dark theme fix :+1:

Hi there @jordi.id96!

I have installed ver. 2.0.1 and it seems too be EXTREMELY heavy on PC resources compared to ver. 1.2.3 I had been using. I have a dedicated Win10 TV box (Z8300, 2GB DDR 3) just for running your app.

With ver.2.0.1 it could not run at all. It simply was not fast enough. It completely drained the little PC’s resources.

What has changed? Why is that?

BTW, do you plan on supporting multiple lights in the future?

Thanks a lot for your great effort.

I added options to tweak movie mode, go to the advanced tab and play with the parameters. Maybe your PC is not powerful enough to run at the default values, but try changing them