Color bulb YLDP06YL IP not found

I bought the bulb from Ebay. First it worked OK under my home router. I then decided to setup another network (with very slow internet connection but fast local connection) just for devices and using another router for them. I reset the bulb and set it to use the new network. For some time it worked fine but then it suddenly jumped back to the first network all by itself as I can recall. Now it does not broadcast its IP at all on neither network. I can reset the bulb but that does not help. I use Advanced IP Scanner to scan IPs. Is there anything one can do to get it back to life?

PS. With AP scanning I can see that the bulb is alive and it broadcasts an IP but that IP is outside my local network IP range, but still a local IP address: Trying to set the bulb off with python3 and yeelight library using that IP gives a socket error: socket.timeout: timed out

I have continued my experiments. I installed an old xiaomi.smarthome apk in my old android phone and it was able to find and get control of the lamp again.

I also found the token of the lamp from a log file in the phone and with those information I can now control the lamp with the Python-miio library. However the yeelight library I use for my other lamps will result in a socket error crash when it tries to set the light on or off for this particular lamp. The xiaomi Mi smarthome setup has somehow hijacked the lamp so that it does not function with yeelight lib any more and requires the use of lamps hidden token.

How can I release the lamp back to use without the token so that I can continue to use the Python yeelight library which does not require the token?

If you can not give an answer to my question your company should at least release a program for users so that they can get the neccessary tokens without any hassle like described above.

Thank you

PS. I also wonder if these lamps are a security threat as they broadcast their SSID to their nearby air and advertise themselves as open AP:s for anyone to connect to them. I haven’t tried if it is possible to hack into them but you definitively should allow them to be password protected and stop advertising as open APs.