Can't add Yeelight JIAOYUE YLXD02YL to app - timeout

Hi there,

I recently purchased 2 Yeelights (JIAOYUE YLXD02YL & YLXD41YL) but i can only get the YLXD41YL to connect to the Yeelight app.
I’m from Germany, so I selected the EU server in the app and upon searching for new devices to add both instantly showed up. Both connect to the router but where the YLXD41YL succeeded and even updated its firmware, the JIAOYUE YLXD02YL can’t get past “Updating connection status” at ~70%. There the counter slowly ticks up to 99% and then displays “Connection timed out”.
Hitting “Try again” results in “Couldn’t connect to device hotspot”. At this point it shows up in my router with an IP assigned to it and its wifi disappeared, I guess hence the error message when retrying. So new attempts always require a reset by toggling on/off five times. I tried hitting “Try again” countless times again anyways to no avail.
By now I’ve tried all the suggested things but nothing changes anything. Tried multiple regions in the app, connecting manually, renaming my wifi, different security settings, multiple DNS, setting up a guest access to my wifi and then mix and matching for good measure… Nothing. I tried to login with both developer accounts shared on this forum, but both got the error message that the username or password is incorrect in both EU and mainland China region.
So yeah… Please help? Why does linking to the app work for one lamp out of the box yet the other one refuses to budge?

Edit: MI ID is 6322071293

I still can’t add the JIAOYUE YLXD02YL to the Yeelight app. Since I last posted the light randomly turned on a few times. I think it might be related to my internet recently being unreliable, but it didn’t happen to the YLXD41YL.
Is there anything else I could try? Or could someone tell me what I’m doing wrong when trying to login with the or so I can try that? In both cases the password yeelink1234 does not work.

Please try to login again. We change the password to yeelink1234.

Thanks a lot! Adding it with that account worked flawlessly. I then updated the firmware, removed it from your account and after resetting the lamp was finally able to add it to my own account without any issues.

I have the same problem
Cannot log in to the above account
Is there a solution?

Try the account:
Account: 2410552805
Psd: yeelink1234

1 Like

Many thanks!!
Successfully connected!!

_guofeng It doesn’t work.
My ID is: 6328558182.
My devide is: Samsung S10/S10+

I have a Yeelight LED Bulb and after reading ALL the replies here, I was trying to connect my bulb but it didn’t work.

  • Tried to login to AND but I coun’t get an access because the password changed.
  • Tried to login to 2410552805, yeelink1234. BUT failed because someone changed the password…
  • Tried to change region to Mainland China and still no success(Used to be on recommended Asia and Oceania).
  • Tried to create new account this time chose Russia as region and still no success.
    It never asked me to update my firmware which is weird
    What now and how can I fix the problem?
    Thanks in advance!

Hello, I tried login to 2410552805 and password is yeelink1234. And it success. Please make sure that you input correct password.