Mi LED Desk Lamp Firmware Update Stuck

Hi, can’t update firmware, stuck at 40%. Tried connect to mobile phone hotspot - the same result. Lixin account doesn’t work now, changed password or what maybe? Model yeelink.light.lamp1 My Mi ID 1605954009 It is always logged in Internet. Please help.

Any support???

I have also Xiaomi Yeelight JIAOYUE 650 and it’ve upgraded recently to new firmware just fine. So it’s not problem of my internet connection i think. What can you propose to do?

Unacceptable level of support, i wrote email also - no answer. Is anybody from YEELIGHT even alive here???

1 Like

I have same problem. Have asked in a few other places for the latest yeelink username & password to do update. Not sure why we cannot get a fix for this from xiaomi server??

Logout your account and login with account: dingyichen@yeelink.net , Password: yeelink1234 from Yeelight application. Then Try update the firmware.

Thanks for answer. But it doesn’t work, wrong account or password. It have only option to enter yeelight account with mi account. And facebook also.

hello. account ID / password incorrect
tried login yeelight mobile app:
username: dingyichen@yeelink.net & password: yeelink1234
Also try xiaomi home app. same error wrong username or password.

Can we update using computer windows?

Hi, this should be the password changed by someone. Please try this account.

guofeng@yeelight.com
guofeng13

Thank you. Login success.
But yeelight send verification code to your email for me login.
Can you send me the code by private message

Try
Account: 2410552805
Psd: yeelink1234

1 Like

login OK success. i try add device now & reply you.

HI Guofeng.

I login your account, OK.
Add desk lamp, OK

Update firmware:
Stuck 40% & after: error: “Update is failed”

What can I do?

Hello, share your device to 268240019. I try to upgrade. Note your lamp as: lamp1 don’t touch

1 Like

Hi Guofeng. After I try again.
Delete device. Add.
Update.

After repeat 3 times update failed.
4 time success!!! :+1::+1::+1:

Finally heard the good news. Haha :smiley:

Hi my lamp connection also stuck at 25%
Userid is 6340895051
Desk lamp 1

Guofeng can help me update firmware please? My app already says latest firmware but doesn’t seem to work. I am on China server.

Hi, it worked AFTER I RENAMED it to lamp, yeelight automatically suggest name with russian characters and it seems this is source of the problem.

Logout your account and login with account:
Account: 2410552805
Psd: yeelink1234

Try update the firmware of your lamp.

I’ve got the same problem but solved now. Instead of using Yeelight app try to install Mi Home app. Log in, add your lamp and update firmware in Mi Home. It worked for me