Model 1S (YKDP13YL) Constantly Disconnects from Homekit

Firmware 2.0.27

Sometimes this light works fine with Homekit, but it generally disconnects at least once a day. There seem to be two ways to get it to connect:

  • Cycle the power. Wait a while. Maybe it will reconnect and maybe not.

  • “Play” with the light for a while in the Yeelight app. It will initially say “disconnected” but after turning it on and then off several times it will eventually reconnect to the Yeelight app. Some time later it might reconnect with HomeKit.

I’m away from home a lot, so these “solutions” aren’t really much of a solution.

I have communicated with Yeelight support on this, but they seem to have given up and have stopped responding.

Please don’t suggest that I reset the light. I have done that dozens of times. It works briefly but then the light starts disconnecting again.

Should I just dump it in the trash and try another brand?

1 Like

There are several similar but separate issues
Connected in Yeelight/Xiaomi but not homekit -> Wifi fine but LAN connection with homekit hub disrupted
Connected in homekit but not Yeelight/Xiaomi -> Wifi fine. No Internet
Disconnected in both -> Wifi disconnected, Check device list in router

For the third case I fixed mine by binding MAC to a fixed IP on the router

Yours seems to be the first issue. I sugguest your router may be blocking some local traffic so try a different router to rule that out.

If it were any of the things you suggest than other devices would be affected. All of my other HomeKit devices work fine. It’s only the Yeelight that periodically disconnects from both HomeKit and the Yeelight app.

The Yeelight has a fixed IP address. Even when it is “Not responding” in HomeKit and “disconnected” in the Yeelight app, I can ping it:

MrMuscle:~ mnewman$ ping -c 3 yeelight
PING yeelight ( 56 data bytes
64 bytes from icmp_seq=0 ttl=255 time=294.554 ms
64 bytes from icmp_seq=1 ttl=255 time=210.619 ms
64 bytes from icmp_seq=2 ttl=255 time=131.438 ms

--- yeelight ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 131.438/212.204/294.554/66.601 ms

Your first statement isn’t necessarily true because a few of my bulbs had issues while others didn’t.
Now since you can ping them Wifi issues can be ruled out, which was what I had. I’ll let others chime in on this.

I never I had a bulb pingable but not show up in Yeelight. For homekit some do become ‘unresponsive’ after a wifi reconnect due to a router restart. It’s always resolved after power cycling

Yes. I can often resolve the problem by power cycling. But, that doesn’t do much good when I’m away from home for a week or two. I need a bulb that doesn’t need resetting or power cycling all the time to keep it connected.

I bought this bulb to replace a Koogeek bulb. The Koogeek worked fine, except that after power outage it defaulted to ON. Which, of course, is no good when you’re away from home and can’t turn it off in the middle of the day. With the Yeelight, you can change the after-power-outage default. But, that doesn’t do much good when the bulb itself is totally unreliable when it comes to Homekit automations.

So, now I’m back to using the Koogeek light because it stays connected.

Here’s another interesting tidbit. When I first got the Yeelight I could use the LAN Control to control the bulb from the command line. Then that also started to fail and now it doesn’t work at all.

I think something seriously wrong with this bulb.

1 Like

I feel you. Unfortunately, too many variables with Wifi bulbs. It could be your router or it could be the bulb. Some routers don’t play nice with yeelight’s wifi chips, which has nothing to do with the router’s quality.

If that were the case then I’d be able to detect the connection problem. I used Wireshark to monitor the connection between my machine and the Yeelight and there is absolutely nothing unusual. The correct packets go out. The correct packets come in. But the bulb doesn’t respond. It’s not networking. It’s something else.

71	3.204375	TCP	101	61551 → 55443 [PSH, ACK] Seq=1 Ack=1 Win=65535 Len=47

0000   5c e5 0c 33 19 21 98 10 e8 f1 c7 65 08 00 45 00   \..3.!.....e..E.
0010   00 57 00 00 40 00 40 06 00 00 c0 a8 00 4b c0 a8   .W..@.@......K..
0020   00 c8 f0 6f d8 93 26 fd 19 4a 16 05 91 9a 50 18   ...o..&..J....P.
0030   ff ff 82 ad 00 00 7b 22 69 64 22 3a 31 2c 22 6d   .....{"id":1,"m
0040   65 74 68 6f 64 22 3a 22 73 65 74 5f 70 6f 77 65   ethod":"set_powe
0050   72 22 2c 22 70 61 72 61 6d 73 22 3a 5b 22 6f 6e   r","params":["on
0060   22 5d 7d 0d 0a                                    "]}..

I did say it could be the bulb. Sounds like you only have a single bulb so it could well be defective.

The 1S bulbs have a bug in the v2 firmware which freezes them after a while. This has been unadressed from Yeelight since a few months now. I have two 1S bulbs which worked fine when i had them on the v1 firmware, after i updated to v2 they are unusable…

So, the only reasonable course of action is to chuck em in the trash and buy a different brand?

Mine are on 2.0.6_0027

Yes, you have the buggy firmware.

I already gave up my hopes for them to fix the issue got myself other bulbs…

Same problem here. I’m completely lost. Dont’t know waht to do more…

1 Like

I’m on 2.0.30, and I have the same problem:(

So its now April 2021 v2.0.6_0030 and all 4 of my bulbs disconnect from HomeKit within 24 hours. I can control them with yeelight app still but not HomeKit. Google router.

Wish I had bought the older color ones they were reliable

1 Like

I noticed an issue with Homekit Hub on my home. The status of my home hub (appleTV) was standby with no other home hub as active. Most things were working except the new g2h Aqara camera for streaming remotely. I signed out of iCloud on ATV and back in, disconnected and reconnected Homekit and camera working better now… as a side note seems like this may have solved the color 1s connectivity issues. It the camera hadnt arrived today I would not have known.

I have a similar issue. Have a bunch of Xiaomi and Yeelight lights but only the LED 1S(Color) don’t work (in my case) in Alexa. They did before just fine, and all the other lights work fine. They work in Xiaomi home and in Yeelight apps so connectivity isn’t an issue, but just for some reason cannot control these anymore in Alexa. Very frustrating, family can’t control the lights anymore.