Could not connect after update

Hello !

I have recently bought 3 Yeelights bulbs. Once I plugged the first one it instantly felt very good, and the same for the others.
But as soon as I updated the firmware, problem started.
I could not connect to the bulb via the app. I tried disabling 5Ghz Wifi (now two different SSID’s for 2,4/5GHz), but my ISP will not let me change primary DNS, only applying new DHCP option 6 (domain name server) rules.
I have one bulb which I resetted: impossible to pair it again: connection issues: it appears in my ISP Box device list but even with static IP and DNS rules added, impossible to finish pairing procedure.
I have another one with updated firmware with strange firmware version*. Which appears shortly after reboot as connected: I can drive it within the Yeelight app (I also tried Xiaomi app but nothing). But after a while it appears offline.
The last one is with the shipped firmware version works like a charms, even usable via cloud with Google Assistant!
Is there anyway to make this work either by downgrading firmware, finding a way to resolve DNS ? I am in France by the way.
Thanks in advance !