Unable to Add Color 1S Bulb to Yeelight iOS App

iPhone XR iOS 13.4
Yeelight Version 3.3.15
Bulb Firmware 2.0.27
Model YLDP13YL

I first added this bulb to Apple HomeKit. This worked fine and the bulb worked well with HomeKit.

Then I installed the Yeelight app on the iPhone. I was immediately asked if I wanted to add the bulb to the YeeLight app. I did. It worked fine and the bulb worked well with the YeeLight app.

Then I did a firmware update for the bulb. I’m not sure if the update was successful or not. I don’t remember what firmware was originally on the bulb.

After that the bulb disappeared from the YeeLight app and can’t be added again.

I have reset the bulb many times. Each time I have tried to add the bulb to the YeeLight app but it doesn’t work.

I have added the bulb to HomeKit again and it works fine.

The only problem is that I can’t add it to the YeeLight app.

The YeeLight app can see the bulb as a HomeKit device.

Obviously, the bulb is connected to my router as it works fine with HomeKit.

OK. Ready to add a device.

Select the device from HomeKit.

It says we’re done. But it didn’t work.

Now YeeLight is inviting me add an accessory detected in HomeKit.

Here’s the YeeLight info from HomeKit.

Here’s the box.

I solved this problem by changing the server from Asia to Mainland China.