can't pair rgbw gen 1 lamps; tried EVERYTHING

Can’t pair two lamps.

Background: two RGBW yeelight first gen. For a couple of years I’ve had them running on my local network, although mostly just with the preset white+colortemp, not much controlling. Then my daughter reset one of them by turning it on and off. I figured I may as well reset the other one too and pair them up at the same time.

In Yeelight app, goes to 50% then “device disconnected”. In mi home app, stops most often at “sending message to lamp”. ONCE has a lamp actually shown up in my router list of connected devices, but the mi home app showed the device as timed out and I couldn’t get any further.

I live in Sweden.
Tried all kinds of servers, but mainly china mainland since that’s what worked before.
Tried DNS 8.8.8.8 on the wifi router.
I shut off 5 GHz.
Tried wifi hotspot on phone.
Tried uninstalling and reinstalling MiHome and Yeelight apps.
Tried installing the apps on another phone, same lack of result.

My wifi ssid/pw only normal letters and numbers.
Both lamps show up as wifi APs.
Pinging ot.io.mi.com works, but slow 300ms.
Phones are Oneplus 5T and 7 (android).
Modem is a ISP-provided modem, Technicolor TG799vac Xtream.

ID is: 1681995770
lamp MACs end in 4243 and 75ce respectively. Probably very old firmware since I haven’t used the apps to control them, and thus not updated them. I don’t feel I need to either, I just want to pair them so I can re-enable LAN control again.

I’ve spent more around five hours on this. Please suggest what I can try next.

Btw - the yeelight app requires me to reinstall it if I logout. All error messages are incredibly non-descriptive. Very, very, very frustrating.

Also tried dns 1.1.1.1
Router firewall setting is lowest
Security is WPA+WPA2, can’t find any setting that says “AES3”
The yeelight app says “server error 1011” a lot (all the time? don’t know, since the error message pops up after a while)
What else…

Everything is just so unreliable, and all errors are so non-descriptive so I don’t know where to start. And to add some context, I design and build internet of things networks for a living.

Can you pleeeeeeaseee recognize that a lot of people use the Yee family of lights in a home automation setting, ie they don’t use the cloud connection and as such only need local LAN access? So please, provide a tool or a way to just commission lamps to the local network and enable LAN control, without having to go through this unreliable and frustrating thing.

Any suggestions?

I’ve tried with another wifi router, still timeout.
Ensured my phone doesn’t do any wifi MAC randomization.
edit: the lamp wifi AP is active still, does that mean the app on my phone haven’t successfully told the light my wifi router ssid/key yet? I see my phone connect to the lamp wifi, but after that… nothing, and timeouts.

@dingyichen do you have any idea what to do?
Can you have a look at logs and see if you can see any lamp trying to connect but failing, and what the reason could be?

Ok sorry for another post in this thread, but I should perhaps also mention that I tried lots of different versions of the yeelight app, using manual installs from apkmirror, going back to 3.1.10 or so. Same timeouts.

I really like the lamps, when I can control them. Now in unpaired state they are too bright and cold for my taste, so would really like to get them back in control.

So does mainland china server work now?

I don’t think the issue is related to version of Yeelight application. This is how the bulbs works when you connect it to the cloud, you can have a check which step do you stuck:
1、Reset the bulb, and then the bulb run as an AP mode. Which means you can see an access point named like "yeelink-light-*** " from Wi-FI list of your phone if the bulb works well.
2、Select the 2.4G network and input password that you want the bulb uses to connect to cloud. Make sure only 2.4G network support.
3、Then Yeelight app will connect to AP of the bulb and send SSID and password you select in Step 2 to the bulb.
4、The bulb will close AP mode once it receives these message and connect to the router. So at this time “yeelink-light_***” will disappear from your wifi list.
5、Then the bulb will connect cloud once it connect to the router. The cloud server is what you select from Yeelight application(Mainland china server, Frankfurt server, American server, etc…)
6、Yeelight app will query the bulb from the cloud, it shows success once the bulb connects to the cloud.

And there’re something wrong with American and Frankfurt server, and the issue has been fixed. So please have a check and try again.

Thanks,
Andy

Hi Andy, thanks for writing me an answer and not just copy-paste something generic :slight_smile:

  1. yep, done that a lot of times. It does the color cycle, and then shows up as a wifi AP.

  2. yep.

  3. does it also tell the lamp my user id, and the server? I ask since, if the lamp then tries to connect to the cloud with my user id, perhaps you can see that in the logs?

  4. most times, this doesn’t happen. It doesn’t disappear, and the app says it times out. That makes me think the message to the lamp doesn’t work properly. Perhaps other things on the phone overwhelms the lamp? Consider eg google photos “oh, connected to wifi, let’s upload everything!” and the lamp just isn’t able to pick up on the yeelight app message?

I don’t have many apps on the phone, and killed them all when pairing, but still no dice.

5, 6) a couple of times now, I have come to where the lamp shows up in the wifi router dhcp list, but the app on my phone always times out. I can ping the lamp on wifi (now 30 minutes). After that, it’s never found and I have to reset it to try again.

I’ve tried 1.1.1.1 and 8.8.8.8 for DNS.
Tried mostly china mainland, europe servers. No successful pairing on any server.
Is there a difference? If I don’t care what server it connects to, which is the “best” one?

I don’t know what firmware version the lamps use, but it’s likely to be very old (2 years?). They (old pairing) is still in my user account (seen as offline), but I can’t see what version they are. Perhaps you can by looking at my YID?
I can ping ping ot.io.mi.com too.

Cause you live in Sweden, I think Germany server is the best.

From your feedback, I think there’s something wrong when the bulb try to connect to the cloud via your router. I don’t know why. There’s no log we can see since the lamp can’t communicate with cloud yet.
The only way I suggest is to connect bulb with hotspots on phone, but you have tried.

By the way, do you have other mi/yeelight devices? Do these device work well?

So you can’t login Yeelight app now?

Thanks,
Andy

I can log in to the app now, works better now, thanks.

The only other product I have is an old Xiaomi wifi router, which works, but I don’t use any kind of cloud connected to that one.

Hm, yeah, agree. The lamps are quite old so the firmware isn’t updated in a long time too. If this helps you, they are still registered to my account on the mainland china server, perhaps looking at those could give some clue. I’ll try pairing the lamps when I’m at either the office or some friend place (corona…).

Again thanks for your help.

1 Like

I found out I have a white LED yeelight too, and that as well can’t pair. Same thing, connects to my wifi, then nothing. That one has spent a couple of years in a box since the color temperature was more pleasant with the RGBW lights.

I’ve now tested the same thing at the office. Tried various servers, both apps, and everything. I consider them broken beyond usability.

@dingyichen have you found anything in logs or such? Otherwise, how can I get these replaced?