Yeelight led ceiling light 650 rgb - radio issue

Im having an Yeelight led ceiling light unit for about 2 month, and recently, at friday the 13th (such coincidence :)) its start to having some troubles with radio control - both BLE (using remote control and wall switch) and wifi (using Yeelight android app).
Everything was normal, until at some point i tried to use remote to switch light mode and light was not reacting. Tried to shut it down using remote and it was not reacting. Then i tried bluetooth wall switch - it managed to shut light off, but with some delay and after not first click. At the same time in app this light was rendered as offline, while Yeelight lightstrip was available and connected to the same network.
I decided to “reboot” it by disconnecting its from grid and reconnecting it. After that light stoped working with switches at all - i did not managed to make any changes using both remote and wall switch.
I tried to reset light by 5 cycles of connect-disconnect. Result - its neither not accessible by remotes, nor showed in app in “Add device” menu. pairing with remotes after reset also was not successful - they just stuck in pairing mode and light did not “breath”
Also its appears to “blink” from time to time - like once an one or two minute at random.

Is my unit broken down or what? Can i somehow fix it? Or i need to get a new one?..