Yeelight bulb II color. Connection timed out. Can't connect previously connected lights

I have 2 led bulbs that have been mostly functional for almost a year. Recently(about 2 or 3 months ago) I got a new router from my service provider (Telstra in Australia). The lights continued to work for another 2 months until I ran into issues with them appearing offline in the yeelight app. I removed them and attempted to reconnect them and now they won’t connect. Been this way for 3 weeks. They say connection timed out at either 50 or 100 percent.

I have tried switching router DNS to google DNS (although not sure if successful).
I have tried using mainland China, Germany, and Singapore servers.
I have tried signing in with account.

My mi Id is : 1786530453.
Please help me this is infuriating

Have a try setup a hotspot with another phone and connect the bulb to it to see if it works.

Same issue, all lights disappeared from my network and are not controllable anymore

Just curious, is your router security using WPA3? I’ve been dealing with the same thing and found that to be the issue. I have some older Yeelights that have been working just fine, but I got some new ones that stopped working after a recent firmware update. I tried all the same things as you, using Google’s DNS, switching servers, and using that yeelink account with a mobile hotspot, and none of it worked. Finally I turned off WPA3 on my Google Nest Wifi and the bulbs magically work now. Hopefully the Yeelight staff can fix this through a firmware update.

I had the same problem, but somehow it was fixed after I sent error reports (from the Yeelight app) of the devices that would no longer connect. I tried lots of things before, but only after I sent the error reports the devices concerned suddenly turned online 5 mins later (and I had been busy with this for 2 hours before!). I would recommend anyone with this nasty problem to try it, it’s very easy and was the only thing that worked for me!

See my full post in the “conncetion timeout” thread:

OK, I was too optimistic. My Yeelight Color Bulbs I and Bedside Lamp still work, but the Color Bulbs II went offline again since yesterday. Once more, I managed to connect to them with the account, but it fails to connect to my own account on the Europe server. Sending error reports doesn’t help anymore. I guess I’m stuck now, just as many others…