Problems updating

So I had a series of problems with my yeelights today. An automation scene was supposed to kick in for my lightbulb and desk lamp, but it only happened in one of my 2 lights. I immediately went to the Mi Home app to check and saw that for some reason my account had been logged out and one of my lights was unresponsive. I uninstalled the app, reset my lights and download the app again.
When setting up the desk lamp, it got stuck on “Checking info” (step 2/3 I believe) repeatedly, so I tried using the yeelight app. It didn’t ask me to do set up, but I couldn’t update the desk lamp to the latest version, it got stuck at 40%. I returned to the Mi Home app, and saw the desk lamp was already set up (how??, it had gotten stuck earlier). But now it won’t update in any of the apps.

Current state:
Mi home app: If I try to set up the desk lamp, it gets stuck on “checking info”, but upon closing and re-opening the app, the set up is somehow done. Won’t update to 2.04_0066, shows “couldn’t update” or gets stuck at 40%. Current version: 1.3.7_0058.
Yeelight app: Update will also get stuck at 40%.

My lightbulb, which was the one that was unresponsive and didn’t perform the automation task at the beginning now works perfectly. It seems the problem with the desk lamp appeared when uninstalling the app, resetting etc.

Thanks for the attention!!


I have exactly same problem too.
I’ve tried reset and setting my phone as hotspot for upgrade.

Hi i have the same Problem with updating Mi Desklamp V. 1.
Current Firmware Version 1.3.7_0058 to Version 2.04_0066.
Yeelight App 3.2.36 get Stuck Updating at 40%. I am on the Germany Server.
Can you help Yeelight?

1 Like

I would also appreciate details by Yeelight what is are the changes in the new firmware - I had really bad experiences with the last updates

I have the same problem!

Firmware update is gone?

Yeelight team could you please share some information? What for was the update, when it will be back, will you delete some faetures?

Hi all! I have the same problem, New Mi Desk Led Lamp, all ok but the app (Yeelight or Mi Home app) can´t update the firmware, from 1.3.7_0058 to 1.3.9_0062.

Always the process stops at 40%


1 Like

The exact same thing is happening here.

Still the same here. Any news?

Hi everyone, i still have the same issue here too when i try to update to the latest version for the Mi LED Desk Lamp 1.3.9_0062. I’ve tried it with both iPhone and Android devices but no luck so far :pensive:

Would like to have the answer as well? Did somebody solve this? No update possible , stops at 40% howto do firmware update?

I I don’t think they will ever solve this problem. I’ve been waiting for a solution for months.