Two Yeelight ylxd01yl ceiling lights unusable after firmware upgrade

Dear Sirs,

I recently tried to upgrade one of my Yeelight YLXD01YL ceiling lights to the latest version

After the upgrade, the light worked until I powered it off.
After powering it on again, it is marked as offline in the app and I cannot use LAN control either.
I can see it registering on my WiFi network (I can ping its IP address) so I know it connects to my WiFi but I cannot telnet to it or use it in the app.

I have tried (several times) turning it off and on five times (reset) and connecting over Bluetooth using the app in order to get it working again. It pulsates a few times and the Bluetooth MAC address becomes visible in the app. However, a short while after I’ve selected what WiFi network it should connect to in the setup, it starts pulsating fast and the app times out.

I had one spare ceiling light as a replacement but when I upgraded the firmware, the same thing happened again. Now I have two unusable ceiling lights. :frowning:

Please help!

Did some investigating using an Android phone as a hotspot.

I’ve found that the current firmware 1.5.9_0189 doesn’t seem compatible at all with UniFi AP-AC-LR, firmware version The ceiling lights will connect just fine to the WiFi but neither the app nor LAN control works.

Please advice!

Tested with an old Netgear WG302 which also does not work.