Yeelight Ceiling require token after upgrade

My yeelight ceiling model:yeelink.light.ceiling1, after I upgrade to 1.5.9_0184 and 1.5.9_0189, I no longer able to remote light without token,

command eg:
printf “{“id”:1,“method”:“get_prop”,“params”:[ “power”, “cf”, “bright”]}\r\n” | nc -w1 55443

I got nothing in response, all the 3rd party program like yeecli also report error while connect to this ceiling light, other bulb is fine,

Is this design for? can I downgrade my firmware?

Could you confirm that LAN control mode is enabled? How about just telnet ip 55443? Any response?

I recently done reset (power cut 5 times) due to I tried add yeelight ceiling to Aqura homekit Hub and surprise me that Aqura doesn’t support it, then I add back to xiaomi (reset 5 time again), I know I was open Lan control mode and reset won’t change the status, but I can’t confirm current status, I only sure I never stop local control mode by myself, I got 5 yeelight product and ceiling is the only one got issue after upgrade firmware (I only upgrade 1 more mono bulb after ceiling upgrade firmware).as I notice firmware since around 1-2 yrs ago starting using “private” token, I mean when use miio discover or mirobo discover, key won’t retrieve.

one more interesting part is xiaomi app report there is 28% packet drop when I upgrade to most update firmware but ceiling light Wifi signal strength is 96%, RSSI -32, I really doubt issue come from my wifi.

by the way, telnet is reject
telnet 55443
telnet: Unable to connect to remote host: Connection refused

(power cut 5 times)reset can make lan control mode to default status(disable status)。You can confirm the status via Yeelight App。Refer to the figure below。

Yes, you are right, but so difficult to use iOS yeelight app to syn with light,

  1. I am not able to choice which wifi to use, I only able to set password,
  2. it just keep connecting then fail and very long time to from 0% to fail.
    after many fail with ios, I try android with success with yeelight app then I am not able to use it in xiaomi and ios yeelight don’t see devices as well,

finally I use iOS Mijia app syn with ceiling again, then I see on android app, light is also usable, then I enable Lan access on android, this is so stupid.
and On iOS yeelight, ceiling light still not in the list

  1. Cause of iOS13 privacy reasons. You should give Yeelight app location service permission. If after doing this, the issue is still there. You should restart your phone, because this is a known iOS13 bug.
  2. Make sure you set the correct password.

Please check if you are using the same account and selected the same server on different apps for the issue of device is not in the list on iOS Yeelight, thanks.

I tried move ceiling light from China server to Singapore, after move to Singapore, I found MiJia app no longer compliant packet drop, that is good new for me, I will move rest light to Singapore these two day, but on ios Yeelight App, no matter I choice Server as China or Singapore, I don’t see yeelight ceiling. I only see it on android app, on android yeelight, I got only 1 ceiling on Singapore and 6 light at China (ceiling also at china but indiciate as offline), iOS yeelight only show 5 light no matter I choose China or Singapore server, and it all shows offline when not at home. I think I better remove the yeelight app and reinstall again

By the way, I am using same a/c between MiJia app on iOS and Yeelight App on iOS and Android.

Also I do authorize all permission to yeelight app for test purpose and still wifi is blink, of cuz I didn’t restart the phone but as soon as I found android yeelight syn first then reset and syn again by ios mijia, that works on both end, then it is still ok, I also found Mijia syn very quick, at least x2 to x3 then android yeelight, and 10x faster then ios yeelight

Due to some technical reason, iOS Yeelight can not get the event of light state change immediately.
For the missing ceiling light in iOS Yeelight, please keep the light on China server, and pm me your xiaomi account.
btw, a beta version in testflight fix some login/logout and offline issues,

Thanks, after remove and reinstall yeelight app, everything looks normal now, thanks for your fully support, as I don’t live in China, and software also suggest me Singapore server, I think it is a good choice to move to Singapore server. main reason is packet lost issue don’t happen again after move to Singapore.

Anyway, thank you yeelight staff’s support~