Yeelight bulbs not working on Alexa, IFTTT & Google Assistant

Same problem with Alexa

Please refer to:

I’m replying to myself in order to help people with Alexa troubles.

SOLUTION:
I had to create a new profile for Yeeligth and Alexa, and it worked like a charm.

Maybe this will not be the best or more elegant solution to everybody, but it was frustrating to not control my house light bulbs at all during the time i was wasting my time trying to get help from the staff on this forum.

Hi, what skill do you use in Alexa to link yours lights? Yeelight or Mi Home?

What does “creating new profile” mean? Do you mean creating new accounts for both Yeelight and Amazon?

Hello, I have the same problem.

My colorful Yeelight lamps are missing from Google Home.

Firmware version is 2.0.6_0065 and are connected to the United States server.

My MI ID 6262295880

Yeelight are you saying the lights will no longer work with Alexa due to a business decision?

This doesn’t seem fair. Some of us solely use these lights in our homes and not being able to control with voice is a pain. What is going on?

What I think they’re saying is this…

Yeelight made devices under the MIJIA brand, for Xiaomi. And was able to control them. But due to the new policies, they can’t any more. You have to use MIHOME skills to control them, not YEELIGHT ones.

So nothing changes. You still can use YEELIGHT skills on YEELIGHT brand products.

2 Likes

Dear Yeelighters,

I’ve bought 3 “Yeelight Bulb Color” in May 2019 and I used two of them until this date without any problems.
The last week, I wanted to connect my last Yeelight and I couldn’t find it on Google Home app.

So, I tried to erase my entire Yeelight configuration… and now I can’t add any Yeelight on my network.

My Yeelight account is verified but I return automatically on the previous page.


If I consider this page (https://thirdparty.yeelight.com/page/app/google-home/link.html?VER=20171128), I don’t see the step 6

As seen on this forum, I’ve tried German and Singapore servers but without any success. Do you ever seen this problem yet ?

Thanks a lot for your help.

For your information, all my problems have just disappeared after the configuration of the new app : XIAOMI MIJIA HOME !

I have 2 yeelight strips and up till a few days ago had no problems at all. I have tried to reconfigure and no luck. I also tried the Mi Home app but it will not detect the strip. I can see them in yeelight and it will add them to alexa but when i try to access them it says not responsive. I was originally on the singapore server. I added a new account for usa and i can add them in no problem and alexa will pick it up but cannot access them by voice or through alexa app. Yeelight app can control them no problem. I disabled and re-enabled the skill witht he usa information and that did notwork. I am stumped at this point. Please help if support is reading this.

@deathrock
Hi Rob,
Do you use Yeelight devices or MiHome devices ? Please show me your Xiaomi ID, let me take a look, thanks.

Hi, i used Yeelight app and working good, but i can’t link with Alexa app because there is not Yeelight skill, just Mi Home skill but i can’t link my smartlight with Xiaomi Home app.

My ID is: 1755034020

Thanks
Pd: I have a Yeelight color v2

@luhaobo
Check it out

Same problem for me in Italy. All my 8 Yeelight Bulbs Color V2 stopped working with Alexa yesterday and again today.
I’m on Germany server.
It’s the third time in the last two months that all my lamps stopped working with Alexa.

Please help me. Thanks in advance.

Had the same problem since the firmware update a few days ago.

How I fixed:

  1. Open Yeelight app on your Phone.
  2. Choose the device
  3. Delete it
  4. Add the devices again and set it up
  5. Go to Amazon Alexa App and try if it is responding now.

But I noticed is not so responsive now as before, it got more delay when you say the command to alexa.

I got it fixed. Just had to get mi home app and register in Singapore to see the strip to add.

Hi,

My Yeelight ceiling light started working again when I disabled the skill on alexa and enabled it again.

The problem persist with the Yeelight LED bulb (color). even if I reset the bulb- reconnect to yeelight app- disabled and enabled skill on alexa- alexa can’t discover the device :frowning:

I have 5 lamps and updated the firmware of 4 of them and they stopped working (only one works now)
Tried new account, different servers, reset Google home, lamps , everything, but still no luck. Is it possible to downgrade the firmware of the yeelights?

My Amazon email is: pietropolizzi@icloud.com