Yeelight YILAI YlXD05Yl 480 - wrong fw ?

I would like to ask if somebody has the same issue as me and if somebody has any idea how to solve my problem with the ceiling light.

  1. Type : Yeelight YILAI YlXD05Yl 480
  2. FW : 2.0.6 0026
  3. Server : China

After 2 months what I (my girl) was used this lamp was everything OK. But one morning stopped working properly. Its turning off from time to time, but the worst is I am not able to change brightness/color/temperature/kelvins, so nothing… I am using the yeelight APP through directly router/wifi so without HUB (this is working in another lamp(type) in another room very well). Through App I can only switch the light off/on. When I try to change the light,the lamp get the signal,because there is some reaction, but it looks like it “immediately” reset to some “standard” value.

I tried reset few times the ceiling (turned off/on and pair with app again), I tried switch fuse on/off, I tried switch servers, but nothing helps…

Could be wrong FW in lamp or the lamp is broken after 1 and half month ? I did an order of the same lamp and I hope I will have no more problems with that.


Similar situation. I use the BT remotes with these lamps, one of them I had the misfortune to update to Now one of my two lamps of this model goes comatose every time I press M button - which an equivalent of playing with brightness and color temperature. I need to kill the power on it (complete reset is unnecessary) to turn it back into a (lamely) operational mode - but it doesn’t help getting back the proper control of brightness and color temp. @Yeelight, PLEASE either release a fixed firmware or provide means for downgrade! This is very disappointing. Given all the abundant complaints about problems after flashing new FW on the vendor’s ceiling light - plus the personal experience - I’m forced to decline all the updates on all my Yeelight lamps (I have 5 of them in total, of different models besides YIXD05TI) .