Wifi on iPhone app not showing up

I just bought a couple of philips wifi bulbs and yeelight light strip and I can not do the first setup because it is not possible to change the network name in the Yeelight app. In the Yeelight iPhone app it is not possible to choose my wifi network, Wi-Fi network name field is locked I use IOS 13.

I tried connecting to the Mainland China Server, and then again with the Singapore one. Tried on the Yeelight App, Mi Home App, tried logging out and back in. I even deleted the apps and reinstalled them after resetting both my iPhone and Router…absolutely nothing!

The Bulb works and turns on fine but there is no way to add it to the app in order to control it!

Please suggest what I can do?

Turn on Location permission for Yeelight in system settings.

1 Like

Ok I got it to work! I tried installing it through my Ipad app it worked, I think my iphone had the latest version of the app which was causing the issue.

Another problem I’m having now is that after I install the Philips wifi bulb it doesn’t show up in my devices?

This is Yeelight, we know nothing about Philips bulb :rofl:

ya sorry I realized after posting it :smirk: