Mi Bedside Lamp 2

I have a new Mi Bedside Lamp 2. Trying to update the firmware but it has been over 2 hours now and it doesn’t look finished. It’s just blinking there. In Mi Home app or Yee Light app, I can no longer see the device is online. Tried adding a new one but the app could not find it. Can you please advice ?

That’s wired, please reset the lamp and add it again.

tried the 2 button reset but doesn’t seem to do anything. In the manual it says it will change color and then resets. But it’s just doing the same blinking. I can manually adjust the brightnesd and all. But it still blinks and I can’t find the device in Mi Home or Yeelight app.

if you turn off the lamp, is it still blinking ?

No, it doesn’t blink if i turn it off.

thanks for response.
i think, maybe there is something wrong with the touch buttons.
before upgrade, have you ever reset the lamp successfully by 2 button?

I brought it to the shop and they couldn’t figure it out either.
They have replaced it with new one and it’s now working fine.