Urgent firmware downgrade request (2.0.6_0051) Home Assistant Unavaliability

same problem here, lost all my lights in homeassisant

This is obviously a pretty big issue now, as many of you are now reporting also having trouble with the latest firmware.

Same problem here.
I have 7 of these bulbs & strips and since the FW upgrade (two of them), lost them in Home Assistant.
Any idea on the delivery date for the new FW to fix this?

I am also having major problems with my homeassist since the firmware updates. Sometimes bulbs get recognized but many are not discovered / are unavailable in homeassist.

Please resolve this bug! Provide new firmware or allow us to revert back to older firmware.

I am also experiencing this problem. My bulbs are useless!

Same problem here!
updated lamps are losing connectivity!


old lamps with v. 1.4 working with no problem

Anyone could provide a home-assistant log message? The lan mode is working normally in our environment, we didn’t know why it’s broken with home-assisstant.

please downgrade me to previous firmware version, please.
Account ID: 62-15-65-31-63
German SERVER

The lan-control mode does work well in out test envronment.
Althrough not likely, there could be a slim chance that incorrect development version was exposed to your device. If that’s the vase, please try out version 2.0.5_0053 (with your mi account whitelisted, you may need to login to china mainlan server beforehand).

It would help our analysis if below ingfomation is provided:

  1. the router’s brand, model and special customizations if relevant
  2. does the bulb shown as online or offline when it’s offline to home assiatant?
  3. is the bulb connectable from LAN when it’s shown offline on home assistant?
  4. any more trace from HA would help a lot

Could you whitelist me, thanks.

mID 1874720391

  1. Asus N66U router
  2. I have manually added the bulbs to my configuration. They show for a while then go ‘unavailable’ for a minute or two. I have heard that automatic discovery is not working at all. I tested it myself and was not able to discover at all the bulbs in Home Assistant.
  3. The bulb is connectable from LAN but drops periodically.

I’ll update and test this evening.

MI ID: 1666852467

Extra info:

  1. Technicolor TC7200
  2. No info shown at all
  3. Dev mode is active in both Yeelight 2 bulbs. No trace of them within Home Assistant.
  4. I have no logs to offer.

Wow I thought it was just me, having awful issues, going offline all the time, have to power cycle to get back online. Can you downgrade me? my MI ID:184856486

Have the same problems. Got 6 lights which disconnect intermittently. The lights were working fine for months until I upgraded to 2.0.6_0051. I’m not even using home assistant, just the yeelight app.

Please whitelist me/downgrade me. MiID: 1896644462

I’m having similar issues.

At the same time writting a program to controls my light from my TV to simulate an ambilight.
If the bulb is toggle to simulate black as set_rgb to black doesn’t really do it, you loose connectivity of it for a while.

On a similar issue with the LED stripe, that one react even worst, you have to power it off completely through plug / unplug power.

Compare to the Bed light, at least the toggle works (not set_power off, it does the same, lost of connectivity same as the bulb).

It really pity, you have such good product and the firmware seems to be inconsistent version to version.

FYI, I am using the music mode to send all command, so it is not related to any quota limitation which the standard protocol has.

Happy to share you by mail any example of issues your different models have. Even can share you some nodejs code which will help you guys to reproduce on your lab.

Cheers,

@liufei

Hi there. I installed the new patch and the device is still showing as unavailable as before. I firmly believe this has something to do with the Homekit intergration… I don’t use homekit but there is a constant notification for Yeelight homekit discovered.

Would it be at all possible to downgrade me?

Thanks a lot

music mode will be aborted if you turn off the bulb. toggle command is an automatic power on/off, therefore it will break the music channel if you “toggle the light off”.

I have adjusted my logic to handle such a case; therefore the bed lamp doesn’t turn off the music mode so it’s inconsistent across your products ;-).

As you said, indeed, I have noticed this thing this morning that music mode is turn off when it’s power off or toggle (to off), but therefore, it’s pity that set_rgb doesn’t turn it to black (power off without really turning off the bulb).

Also, notice that if you are pushing the music mode to fast to the bulb/stripe (after your turning off the device to dim light to black) you are crashing them forcing your to power off / power off manually. It is what produces for me timeout of the bulb, now following this limitation it avoids it.

The workaround of that is to respect a window of 150ms (for the bulb) / 200ms (for the stripe) before you are sending back the instruction.

I really believe you should follow one of these two implementations

  • Option 1, allow set_rgb to dim more the light to reach even “black” which mean no color
  • Option 2, an additional music mode parameter to make it persistent:
    set_music 0: turn off music mode
    set_music: 1: turn on music mode (power down device will turn off mode)
    set_music: 2: turn on persistent mode (mode has to be manually turned off)

A small edit, to notify you about your documentation (https://www.yeelight.com/download/Yeelight_Inter-Operation_Spec.pdf) that is not accurate to your current statement:

NOTE: When control device wants to start music mode, it needs start a TCP server firstly and then call “set_music” command to let the device know the IP and Port of the TCP listen socket. After received the command, LED device will try to connect the specified peer address. If the TCP connection can be established successfully, then control device could send all supported commands through this channel without limit to simulate any music effect. The control device can stop music mode by explicitly send a stop command or just by closing the socket.

Thank you for your support,
Cheers,

1 Like

In order to reproduce the issue you described, we downloaded home-assistant and run it successfully in VirtualBox. The management portal is working, however, I can’t find how to enable Yeelight plugin (or addon). Please give us some hint.

I can help on wechat if you would like? wechat id: danedwards_fin

Yeelight component is already on Home assistant.

If it is not finding your bulbs automatically. You can add them to your configuration.yaml like this, obviously with the bulb IP

yeelight:
  devices:
    192.168.1.25:
      name: Living Room

This should force Home Assistant to try to connect to the bulb, without discovering it automatically.

More information:

Also I found these messages in the error logs

Unable to update device 192.168.10.196, Bedroom: Bulb closed the connection.

1:51 PM components/yeelight/__init__.py (ERROR) - message first occured at 1:40 AM and shows up 26 times

Unable to update device 192.168.10.138, Entrance: Bulb closed the connection.

1:49 PM components/yeelight/__init__.py (ERROR) - message first occured at 1:25 AM and shows up 25 times

Unable to update device 192.168.10.196, Bedroom: A socket error occurred when sending the command.

1:46 PM components/yeelight/__init__.py (ERROR) - message first occured at 1:18 AM and shows up 11 times

Unable to update device 192.168.10.69, Living room: Bulb closed the connection.

1:10 PM components/yeelight/__init__.py (ERROR) - message first occured at 1:57 AM and shows up 17 times

Unable to update device 192.168.10.138, Entrance: A socket error occurred when sending the command.

11:56 AM components/yeelight/__init__.py (ERROR) - message first occured at 4:31 AM and shows up 8 times

Unable to update device 192.168.10.69, Living room: A socket error occurred when sending the command.

11:28 AM components/yeelight/__init__.py (ERROR) - message first occured at 1:21 AM and shows up 12 times
1 Like

More info here:

and here: