Homekit very unstable work with Homepod

I update my Yeelight LED Bulb (color) to newest Firmware 2.0.6_0051
And add to home app. But its just work for few minute, After that some bulb start to no responsed.
This phenomenon also appears in yeelight striplight (2.0.6_0063)
Meanwhile its No Response in Apple home app, It can still control by Yeelight/Mihome. So i guess that perhaps not a network issue. But some firmware bugs.

I might find out the reason. Once I unplug my homepod, every bulb just work fine with iphone. Maybe homepod keeping request status too often make it crash?

P.S. Before the official support of homekit. I was using the lan control work with homebridge. Its worked very smoothly. But newest update complete destroy lan control function. Homebridge keep logging [homebridge-yeelight.yeelight] failed to connect.
So I can’t go back to previous method neither.

I also have Mi Desk Lamp Pro manufacturer by Yeelight. Its perfect work with homekit. So I believe yeelight have the ability to fix this problem.

Hi,

Would you describe a little aboout your wifi router? We just found that, if the wifi is working on AC+AP or mesh router setup, apple home sometimes fails to do mdns discovery, after switching out of and back into the wifi spot for several rounds.
It could be some bug with the router. We will keep on doing more test to make sure. But it helps a lot, if more information is provided from customer side. Thanks.

  • br, Liu

It happens to me too but in my case even the Mi Home and Yeelight app shows the bulb and the strip were offline, I use Google Wifi as my main router.

Yes
I’m using a main router in the living room, and with a secondary router working as AP mode in the bedroom with all Bulbs connect into.
In this case Bulbs last less than 3min.

I tried to turn off the bedroom router and connect Bulbs to the main router. This time last about a few hours but eventually all Bulbs offline at home app.

I’m having the exact same problem. Sometimes turno the power switch for the bulbs off then on again makes they work again, but only for a short time until they are unresponsive again (even if they work perfectly fine on Yeelight App)