HomeKit doesn’t work

Hello,

After I updated Yeelight Color Bulb (with violet ring) to 2.0.6.0051 it still doesn’t work with HomeKit. It’s now has menu item Add to Home indeed. But after I do everything it doesn’t go further than “Search for Accessory”. I attached video of that process for better understanding.

Bulbs connected to server in Germany.

Video: https://share.icloud.com/photos/0iJPaPexekAqRn5YrYlg8e5CQ

I’m having the exact same problem. I turned my lights off than on again, and I managed to connect them both. But, an hour later, HomeKit said that the bulbs were disconnected. I removed them and tried to add to home again, but this time it keeps searching endlessly.

I’m not at home so I can’t test it, but did you tried to add the bulbs to Homekit using the Mi Home app? That might be a solution…

I have the same problem. Tried on both Mi Home and Yeelight app, and both on ios 12 and 13 beta. None of them worked.

I managed to connect my lamps to homekit by reseting them to factory setting, adding them again on the Yeelight app and them adding them to home.

But it doesn’t work all times. Sometimes only one lamp is connected, sometimes both are disconnected and can’t be found by the home app (although they work flawlessly on the Yeelight app).

It seems that some updates will be required for them to work as they should…