Bedside Lamp 2, stuck on "Updating connection status" after Wifi switch.

Hey, recently got a new internet connection and after setting up the new router the Bedside Lamp 2 can’t complete the setup.

  • I tried already all different servers. Nothing.
  • It’s not possible for me to change the DNS in the router, it uses the ISP DNS, but my Yeelight LED Blub can complete the setup without problems.
  • I tried to connect the lamp via a Hotspot from my phone and connected it via the tablet, this worked but the Lamp is now stuck on that Hotspot, so not usefull at all, still enough to confirm that the firmware was up2date. But somehow it was impossible to complete the setup when the tablet was hosting the Hotspot and the phone was establishing the connection, those two use the same contract/ISP.
  • I can see the lamp in my router and assign a IP manually, but that doesn’t make much difference, still cant finish “Updating connection status”.
  • I’ve reset and retried connecting with all kinds of settings, 2.4ghz only, different channels, different SSIDs, setting the Hotspot SSID and password to the same my router uses in the hope it uses that when the Hotspot isn’t available.

At this point I’m all out Ideas. the first time setup was so smooth and easy, the Bulb still works fine, so I don’t know why the Bedside Lamp doesn’t play along.

Hello, could you have a check which firmware version of the lamp? And what’s your xiaomi account.

I am not sure if your are the case:

Don’t remember what firmware it was, but the app said that there are no updates, I can try to check tomorrow. For the account, it’s 1669871510.
Thanks for the fast answer :wink: