The device can't be seen in router DHCP

I have a Yeelight ceiling Light Pro & 2 Plus.
However, when I reset the device, the device can be seen on my iphone wifi list but not on my wifi router DHCP list.

I tried to use app to connect the device but there’s always time out error message. Any suggestion for this?

If you reset the device, it will start a hotspot named like “yeelink-light_ceiling***”, it will connect to your router once you set SSID and password to it from app.

BTW, what’s your xiaomi account?

Once reset, the hotspot name showed on phone’s app but not the router HDCP list, when tried to connect and input the router SSID & password, timeout error message appear and it lose connect.

My axxount is 6193694251

Seems your account are in the case, please refer to:

It seems to be the router problem.
I used ASUS RT-AC88U as the wireless router and failed.
Then I add an used RT-10N+ wireless wouter adter RT-AC88U as an extra wireless router and connect Yeelight products to RT-10N+, everything works. But I hope somebody can tell me how to use AC-88U to do the work to save a device in my room.

Are the 2.4G and 5G names of wifi hotspots separate or identical?

It’s separate.