LED Bulb Color version 2 Connection timed out

Hi all,

I’ve recently moved to a new apartment with a new modem which my version 2 led color bulbs have trouble connecting with. Other devices have no trouble connecting. The bulbs have been reset and I’ve tried setting the DNS server to and with no succes. After hitting 50% progress slows down and at 100% I keep getting the error “Connection timed out”. The modem I’m working with is a draytek vigor2132F and I’ve set my yeelight app to the (suggested) German server (ID 1917653912). Any advice would be most welcome.

Could you try setup a hotspots with another phone and try connect the bulb to it to see if it works?

All bulbs work fine when connected to a hotspot. What do you suggest as a next step?

It seems your ISP blocks xiaomi domain, please login into page of administration of your router, change DNS to and have a try again. Most of the cases can be resolved using the trick.

As you can read in my original post I have already tried that solution. What else can you suggest?

I read your post, I mean you can try again.

There’s a trick you can have a try, setup the hotspot with the same name and password with your router, turn off the router, connect the bulb to it. After the bulb is connected, turn off the hotspots and turn on router again to see if the bulb back online.


I understand what you mean, thanks for the explanation! I’ll give it a try and let you know :slight_smile: