Request expired when trying to connect the connected lightbulb

#1

Hi,

I bought 2 Xiaomi ceiling light a month ago and got them working in 5 minutes in my apartment with no issue. My parents got 2 ceiling lights too from Xiaomi/Yeelight 3 week ago, and they couldn’t get it to work yet.
My dad reset the light countless times, uninstalled/reinstalled the Xiaomi Home app too.

Basically when he tries to connect the light, the 0-100% thing appears and starts running, and eventually when it reaches 100% ( sometimes even before ), it displays an error message :
In French it says " Demande expirée ", so it’s like " Request expired " or " Request timed out ".

At first they had a 5GHz Wifi channel along with their 2.4GHz, so I made them remove it since perhaps it was the cause. But it still doesn’t work. They tried changing the region to French ( it was set on Germany by default I believe ), either way, it didn’t work.

Perhaps it was because of the phone, I have an iPhone 7 and my dad has an iPhone 6, but it doesn’t work for both phones at my parents’.

What could fix it ?

Not sure if there’s much more to say, but if you want any more info, just ask

Thanks

#2

Hi,

Please make sure if the lamp connected to router, if yes, try changing DNS of the router to 8.8.8.8 and connect again.

Thanks

#3

Hum… I think it is connected to the router, I’m not sure though, how can I check that ?
The app asks my dad to connect to the yeelight wifi, and it works, but I think it prompts him for the wifi password another time after the connection failure.

#4

Check DHCP list from administration page of router to see if the bulb connects to the router, and also from where you can change DNS settings.

#5

Thanks, I’ll tell him to do so