Set scene by API

#1

Hello,

I’ve been reading and searched a lot about Yeelight API and I didn’t found how to do 2 things:

  1. How can I connect on API to do requests on internet (out of LAN).
  2. How can I set a custom scene to a bulb.

Could anyone help me with that?

Cheers

0 Likes

#2

1.There’s no API of control device via internet.
2. Format of custom scene is below:
{"id":1,"method":"set_scene","params":["cf",4,0,"3000,1,16711680,50,3000,2,2700,50,3000,1,16711680,50,400,2,2700,58"]}

0 Likes

#3

Hello,

  1. How can IFTTT control the device then? If it just allow access on LAN?
  2. I didn’t understood these params. Scene already was created on Yeelight app and just want to activate it.
0 Likes

#4

Hi dingyichen

I´m using a Yeelight YLDP06YL with firmware 1.4.2_0035 (updated) with Yeelight app (latest version) and I created a scene in my Yeelight app that works fine in app.

My Yeelight app is working ok. I can do anything.

I’m living in Brazil and I’m using the US Server and my ID is 6172158365

In my Gooogle Home app (latest version) I can see my bulb with all scenes assigned to the same room.

I can turn on, turn off, change brightness, change color normaly using my Google home,
but I can not activate any scene.

When I say or type Activate “SCENE NAME”, the Goggle Home or Google Assistant say “You got it, activating the SCENE NAME” and nothing changes in my bulb, the bulb stay in the current state.

But in the Yeelight app all the scenes are working perfectly.

I´m already say “sync devices” many and many times and the Google Home respond “ok, synching Yeelight devices” , but the problem persists.

I’m already tried remove my device, add again many times and create new scenes with different names but the problem persists.

Can you help me please ?

Thanks so much for your attention

0 Likes

#6

@saintchelo
Hi,

I’m sorry to hear that, I just found root cause and fixed it. please have a try to activate scenes, if you have any difficulty, please reply this post.

Thanks,
Scott Yu

0 Likes