Cannot go from Flow state to Regular light

Here’s what I set up (as a timer light before going to bed):

  • Brightness 25% 10s
  • Pause .5s
  • 1% Brightness 2.5min

Here’s my problem:

  1. It doesn’t start if I don’t have the Yeelight running. This means the shortcuts, etc don’t actually turn on the light.
  2. But the app registers the “flow state” as being active and the light being on! I have to wait until the flow state runs its cycle before I can do anything.

I’ve tried to turn off the light and back on via the app and via Google Home, but the light stays off (although the app shows it’s being turned on).

As I see it there are two problems:

  • If using shortcuts to activate customized flows/states from outside the app need to be sure there’s a hook to the yeelight making it active somehow.
  • Flow states need to be able to be interrupted, because I can see that I may also want to restart the flow while the flow is already active.

Hopefully this makes sense, and you guys can help. Thanks!

maybe @coasterli or someone else can help?

We will look into it.

@vevola I didn’t get your point. You can turn off the light or restart the flow at any time, even there is a flow running.

Well that’s not working for me…

If I try to click to restart the flow action while I see “flow” already activated (so clicking on it again like you say), it does nothing.

Basically if I try to launch my customized flow via a) a Yeelight shortcut on Nova launcher or b) using a Tasker shortcut, then I get stuck with the light not being accessible (even if I click the shortcut again, even if I try to turn on/off/on the light via the Yeelight app or even Google Home) and I have to wait before the Yeelight becomes accessible at all. If I start with the Yeelight app already open, I’m able to launch the flow (and it works), but if I try to restart the flow action while it’s already running, nothing happens.

FYI I also tried to reset the light a couple of times.

  1. what do you mean [quote=“vevola, post:5, topic:10588”]
    I have to wait before the Yeelight becomes accessible at all
    [/quote] ? Click the icon to launch Yeelight app manually?

Please also double check if you have grant the permission of Launch In Background for Yeelight app.

  1. Could you take a video for that?

@Coasterli I just tried now (sorry, video is difficult for me now). here are the steps:

  • Launch Yeelight app.
  • Press light on: works fine.
  • Press light off: works fine.
  • Launch the flow scene (described above): it briefly turns on for a second, then shuts off. The bulb’s description shows “flowing” .
  • Press flow again: the bulb’s description continues to show “flowing” but nothing happens.
  • Press light off
  • Press light on: app shows the light is on and “flowing”, but the physical light is still off.
  • Wait 3 minutes, press light on: app shows bulb is “on” and “flowing”, but physical light is not turning on.

At this point i can’t do anything else with the Yeelight. Even after 5 minutes, which is more than the flow state total duration, the light bulb is still off and the app still shows it as “flowing” (tried toggling on/off from the app a few times, but nothing).

I’m facing similar issues with my LED strip v2. The bulb automatically goes into flow mode right?

i think you can avoid it for a while by using another scene like “sunset” mode, turn off, turn on.

But unfortunately, after some time, it automatically goes into flow mode again.


So it seems with the latest updates the problem has been fixed, just wanted to let you know - thanks!

It seemed to work for a while, but now is buggy again.

I have to physically turn off/on the light before the app recognizes it.

When I try to turn on the flow state from the Yeelight app, it flickers on for a second and then turns off and then the light becomes unresponsive to any input via the app. The only “fix” is to physically turn off the light and turn it back on, waiting a minute, and then I see the light state as “on” in the app.

I’m on German server, firmware 1.4.2_0055 (which seems to be the latest), with LAN control enabled, app v. 3.2.08 (but the previous 1-2 updates didn’t work either).