Yeelight smart bulb - can't connect/show in Yeelight app/Xiaomi app


#1

Hello,

I have recently bought YEELIGHT 10W RGB E27 Smart Light Bulb and I can’t get it to work. Bulb’s wifi is visible in WIFI settings and I can connect to it. In Yeelight app, I connect to this wifi network, then connection is either stuck at 25% or it immediately shows me message: “Please check your device and enter the correct info”. I have also tried in Mi Home app, I am able to connect to the bulb, can select room and bulb’s name, but then… it is not visible in main menu or under any rooms. I have tried several times both connections. Please let me know if I can get it to work somehow. I am using iOS phone and my wifi is configured as WPA2. Thanks in advance!


#2

1、The bulb can only work with a router using WPA / WPA 2 encryption method with a password, 2.4Ghz. 2、Please make sure if the bulb connected to your router when the connection failed.
3、If connected, please try changing DNS to 8.8.8.8.


#3

Hi, router is working on WPA2, 2.4 Ghz. What do you mean by checking if bulb is connected to router? Where should I check it? Also, where to change DNS? On the router?

Thanks in advance!


#4

Login administration page from your PC, check DHCP list to see if there’s new device connected. And you can also find DNS settings from the page, try changing to 8.8.8.8.


#6

I made it work via xiaomi app. The only thing I did is that I changed server to mainland china… It is still not working via Yeelight app. Immediately disconnects on connection process. I also checked on routers devices list and bulb is there, connected. Anything I can do to make it work on yeelight app? Not very convenient to use it on mainland china server…


#7

Any help with Yeelight app? Pics attached