Suddenly since today, none of my 3 smart lights work


#1

Hello guys,

I have been very happy with my Yeelight products until now. I use the Mi Desk Lamp, Light strip and RGBW bulb. Everything worked well for months, installation was flawless and Google Assistant worked perfectly with Singapore server.

Now today, I tried turning on my usual scene in the Yeelight app, and it doesn’t work. It shows the lamps as offline. I check if they maybe lost connection, but all 3 lamps show up in my router.
Next, I delete the app data, reinstall it and log in. Still offline.

I remove every device, reset every single lamp and try to set it up again, but it seems that it can’t reach the servers. I suspect this because my phone finds all 3 lamps when reset, the WiFi scan is sucessful, the phone shortly connects to the lamp to push the data, and then nothing happens. The lamp is connected to WiFi, I see it in router interface, but can’t talk to the server I suppose?

Any idea? Maybe a Yeelight server IP address I could try to ping from my computer to see if it’s my router that can’t reach it?
I’m pretty much clueless.

Other than that, I really have to thank you for the amazing products you have put out there. I am very sad not to be able to use them right now.

Kind regards,
David


#2

Weird, I now restarted my router once more time and it seems to work again. Not sure if it stays like this but for now, my problem is solved. Sorry to bother!


#3

I found out that is best to turn off everything (including router!) and then turn on router, and only then bulbs. If you only reset bulbs, burn them on/off (physically) some bulbs always refuse to work. So in case something happens, turn off router as well.


#4

Yes, you’re spot on, that fixed my problem.

What I think happens is this: Yesterday night my internet cut off but my router was still on. So the lamps were still connected to the WiFi but lost connection to the Internet, i.e. Yeelight servers.
Also, when I restarted my router to try and fix it, I left the lamps on. So they instantly connected to the router which needs 2-3 minutes to get connection to the internet.

Now on my last try, coincidentally, I did exactly what you said. I turned on the router, waited, and only then turned on the lamps. Worked without an issue. Since this was my first issue in months, I guess that’s it. Kind of good to know though.

Cheers


#5

Thanks for your feedback. We will look into this issue in our lab.

Please let me know the firmware version.


#6

Actually, when I created this thread it was the only time I had this problem. I don’t know if it’s fixed, but there was a firmware update which improved network connection a few weeks ago, maybe that was it. I always had the newest firmware, today I updated to _0061.

I think the problem was this: I have a fiber connection and when I restart my router, WiFi is on immediately and internet only connects after 5-10 minutes. So the Yeelights connected to a WiFi without internet and maybe there it gets stuck. But as I said, no problems for over a month now:)


#7

We will look into that issue. If you could help to verify it in latest firmware will be great!