Problem configuration Yeelight RGBW LED bulb (iOS App)


#1

Hi Yeelight,
I recently bought your “magical” light bulb and I tried to associate it and configure it with the iOS app on my iPhone 6.
Unfortunately, after having logged on to my Xiaomi account, you enter the password to my Internet line and you have selected the visible light bulb in the wi-fi devices, the app gives me an error at this point to the configuration: “Device is connecting server”. I also made a screenshot to show you.
I tried to configure the Yeelight RGBW LED with the app Mi Home is working perfectly, but I would still test your app, how can I fix this?
Thanks in advance.


#2

Could you logon to your router and check if the bulb has been present in the DHCP client list? If this, that means the bulb can’t connect to the server from your ISP. Then you may try to “ping ot.io.mi.com” to see if this destination is reachable?


#3

Thank you guys,
I followed your advice:

  1. I checked the Yeelight RGBW LED appear in the DHCP client list, and was present;
  2. I tried to ping to “ot.io.mi.com”, and has successfully managed to communicate (to do this with the Mac I’ve used “Utility Network”.

After making the ping I managed at last to add and connect the device to your app for iOS. Thanks guys!

At last I wanted to ask if you can add in iOS widget’s the ability to insert one or two favorite scenes?


#4

Regarding the widget, we will improve it to make it more convenient.


#5

Hi guys,

I have a same problem and I’ve followed the instructions and still not working. I’ve checked the ping on ot.io.mi.com and its successfully received but the device is not connected to server.
Can you help me?


#6

When did your offline issue begin? After a firmware upgrade or it just happened someday suddenly? Could you firstly check your bulb can connect to your router successfully?

You can also let us know your XiaoMi ID and we will take a look at our server side.`


#7

I bought my bulb white on saturday, until now it’s not working. I cant connect to server. But my bulb can connect to the router successfully.
My id is 1640803781.

Please help, because i think my bulb is useless now.


#8

could you ping “ot.io.mi.com” from your PC which is under the same router with your bulb? If it’s not reachable, then you should check with your ISP.


#9

Like i said on above, it’s reachable. I feel so desperate with this bulb.


#10

Sorry, lost the context… Could you try use your phone as AP and connect? We will check the log on the server side tomorrow.

We don’t officially support global market right now and all these products are being sold through some unknown channels which means we haven’t fully tested the connectivity, so we also feel very desperate under this situation.


#11

I’ve tried with my friend’s phone (personal hotspot) and it’s working, but when I tried with my wifi it’s not working. My ISP said, your IP is blocking my ISP not my ISP is blocking you. I don’t understand. I’m so confused


#12

OK, they it may be related to the notorious Chinese Great Firewall … :rage:
Another option, please download MiHome application and try connect the bulb to Singapore server. The only shortcoming of this option is that some function is missing.


#13

I’ve connected to singapore server and It’s still not working. LOL

I don’t know how to fix this, maybe i cant use all of yeelight products forever :cry:


#14

Really sorry, I don’t know how to handle this … Maybe give it to your friend is the last option… Or you can ask for a refund from your retailer.


#15

Yes, this works for me too. I can use my iPhone as a hot spot. But it doesn’t allow the bulb to connect through my Apple Airport Express router.

Can Xiaomi tell us what settings we need do do to allow it connect through the airport express?


#16

The latest firmware has a compatibility issue with Apple router, we are working on that. Sorry for the inconvenience!


#17

Many thanks! looking forward.


#18

I wanna ask. I’ve used mi home and singapore server but there isn’t option to use yeelight bulb white. So i just used yeelight color bulb, so that’s why i cant connect to server. Do you have a solution? Or can you add a yeelight white bulb to singapore server?


#19

Both white and color bulb are supposed to be supported. Could you post a picture of your screen to show us the problem?

If you have already connected the bulb using Yeelight app, that means the bulb has connected to China Mainland server, which won’t be seen from other server. You need to reset the bulb and re-configure it with MiHome and Singapore server.


#20

Curious question. Why do the bulb have to connect to the mainland server? Why not just connected locally through the router?