New router - cannot connect to LED Strip

Hello everyone,
recently, I have been forced to change my WiFi router to ZTE brand. Since then, I have been unable to connect to my LED lightstrip.

After changing my router, I have restarted my LED lightstrip to factory settings and tried to setup it as new device. I always got stuck at 25% till app “time out” my connection.

I have tried several things to solve my problem, always with same “timeout” outcome.

  1. Creating new SSID with lower / no security and simple SSID name, like “TEST” for ex.)
  2. I tried another (brand new, unused) LED Lightstrip
  3. I re-installed my iOS app
  4. I tried all 3 avaiable servers
  5. I tried multiple mobile devices (Android & iOS)

I am really running out of ideas guys.

Thank you for any useful ideas and sorry for my english, I am not a native speaker :slight_smile:

Best regards

Could you log into your router and check if the strip is present in the DHCP list after you got 25?

Hello, thanks for your answer.
Yes, it is connected. I can see it in list of connected devices (screenshots here: and and light on the controller is blue with no blinking.

But I am not able to see any devices in my iOS app, becasue it gets stuck at 25%.When I manually restart app, LED strip remains connected, but there is no device in device list.

When I wait enough time, I get message: “Connection failed, please check you device and enter the correct info”.

Seems to be network issue.
Which server are you using? Which App are you using?
Please ping or If possible, you can change your router’s DNS server to instead of using automatically allocation.

I tried to ping both servers you mentioned, no success
I am using Yeelight app for IOS and iPhone 7.

edit: and I am using this DNS settings:

I’m not talking about the DDNS, please check DNS server settings, normally it can let you choose automatic one or manually specify one.

I did some digging about my router (ZTE II) and there is no way to change DNS. I’ve got this router from my internet provider with custom firmware and there is no way to change DNS settings :frowning: