Mijia Bedside Lamp 2 no wifi connection


#1

Hi Guys,

i’m not able to connect the Bedside Lamp 2 to my wifi.
The mi app stops at 100%.
The Yeelight app also show connect not possible.

I also tried a lot of Location.
I tried to setup the connection on my iPhone and on the iPad.
Both got IOS 11.2 Beta2 on it.

There is also nothing shown up on my DHCP server.

Is there a problem with the servers or the IOS App?
Is there any rule for the WIFI name, my WIFI name contain / and .

Cheers Robert


#2

You should follow the step by step instruction of the app. The SSID/Password is sent to the lamp through Bluetooth, you should enable your bluetooth on your phone.
BTW, if you could post some screenshots here, it would be more helpful.


#3

So i found out the problem.

The lamp is not accepting a wifi ssid like mine.

My ssid is the following:" wifis.org/fliggl/0"
if i change the ssid to “wlantesting” an try to add the lamp to my wifi it is working.
So there is bug in the mi software for IOS or the bug is in the firmware of the lamp it self.
Looks this should be tested at xiaomi.

If you need any further information or help please let me know.

Cheers Robert


#4

same for me: with “pretty-fly-for-a-wifi” - maybe some issue with special caracters (+, - , &, : , etc.) ??


#5

In my case I have two Bedside Lamp 2. And one is faulty because It goes offline when its on.
I have a group with the two lamps, and after changing the colour some times, the faulty Lamp stop responding and appear as offline.


#6

Did you use iOS or android?
So we Can See where the Problem is coming from?


#7

Android, but the problem is from the lamp, because as I have said, it stops responding and change to offline, losing the control.
The other lamp works perfectly.


#8

you are not Reading Right.
We don’t have a lost connection or a lamp with no responding.
We are not able to setup the WiFi.
There is major bug which is not accepting ssid with special characters inside of the ssid.

That means you are mixing to different problems here.


#9

If your lamp is not faulty, then change your SSID


#10

To change he ssid is no option.
There are to many devices with the “wrong” WiFi name.
But at the moment I use an multi ssid setup to get the lamps working.

The special characters which I use are allowed be ieee
So xiaomi is not using the standards for WiFi


#11

It’s not about none standard WiFi, the firmare didn’t handle the SSID properly, we will update the firmware to support special characters in ssid.


#12

I tried what you said, because my lamp was disconnecting all the time, losing the control.

I have created a guest SSID “MiWifi” without hyphens or dots (my other SSID is NAME_2.4Ghz)and now it seems that the lamp doesn´t disconnect.

Still testing…


#13

but this is not the solution, that we change our SSID - since usually there are a couple of devices you have to reconfigure.


#14

We have to wait for a new firmware. At least is good to know that this is not a hardware problem.


#15

Is there a timeline for the new firmware?

If you need an beta tester for the app or the firmware please let me know.

Cheers Robert


#16

Just installed the new firmware in the las few minutes.
The problem with the wifi ssid is still there, the apps hangs at 100% and nothing is happening.


#17

Hi, I have a similar problem. My Bedside Lamp 2 was working perfectly with my current Wifi SSID. It was connected to 2 BTE Temperature and Plant Monitor (as bridge).
This night stopped working and now I cannot reconnect to the Lamp. I have done a Factory reset (Pressing long the button and pluging in) but still not discoverable.
What can I do?
Also -> If I check My Wiaomi Router, Lamp is still connected via Wifi, even after doing Factory Reset on the lamp Several Times


#18

How did you reset?


#19

As manual said: Long press on the main button while not pluged in, and pluging in into AC


#20

No, that’s for Bedside Lamp Gen1.

For Gen2, you should press both buttons on top wheel and hold it for five seconds. When the lamp start to flash, you are good to go!

But, I don’t think Factory Reset will help for this case.

Show me your xiaomi id and I will check from backend.