Mijia bedside lamp 2 immediately lost connection


#1

Hi everybody. I’ve just bought the new lamp and tried to connect it both with Mi Home app and Yeelight app. The same append try with one or the other.
After a reset the apps are able to see the lamp and to connect to it. After the connection the lamp is visible online in the main window but as I tap on it, it says the lamp is offline.
I can’t even upgrade the firmware even if I see the notification cause, again, as I try the lamp seems to be offline.
Only the very first time I connected it I was able to change its colour but just for like 10 seconds.
After that I tried and tried but every time it connects and then says the lamp is offline.
Please **HELP! **


#2

I attach some screens:


This is what appends if I try to update firmware as soon as the lamp is connected. Starts from +1%, jumps to -1% and then stops asking to retry.
Next screens show from both apps that the lamp is correctly added but offline


This last one shows that the lamp is seen connected to my WLAN by my router.

I’ve tried with both the app locations either on mainland china and US but there wasn’t any difference.


#3

SOLVED
I was about to give up but suddenly I accidentaly managed to make it work in the easiest way possible. I just switched it on and off rapidly for 3 times and then refreshed the yeelight app homescreen and voilà, it was online. I have immediatly updated the firmware and now everything works fine.
Hope this could be helpful for someone else.


#4

Glad to know it works for you. Enjoy it.