MiHome scene - 'Abnormal Error' on all yeelights


I have a problem with running scenes with the MiHome app and all off my yeelights. For example a scene: when my aqara motion sensor sees motion, it should turn on my yeelights ledstrip. I can see in the MiHome app that the sceen is triggered by the motion sensor but it gives an error: “Couldn’t complete action, try again”. In the error-log details, it shows the message “Abnormal Error” on the yeelight.
This problem comes up when a scene is triggered and has to turn on or off the yeelights.
When I connect for example the gatewaylight to the scene to turn on or off, it works perfectly.

Turning manually on / off the yeelights with the Yeelight and MiHome app works ok.

Can you kindly give me an advise what I can do?

Anyone any idea? It drives me crazy… I can’t get it to work. I delete all devices in both apps, tried with a new mihome account, reset all devices but nothing helps.

I hope this can be solved somehow. Thanks

When I use an Android phone, i can see Some more details when I tap op the words ‘abnormal error’
It says:
1- Poor network condition
2- Device error
3- Server error

My thougts:
1- as i can control the yeelights manually with the app, I don’t think this Will be the problem
2- same as 1
3- this can be a problem but what can I do on this item?

I have the exact same problem with one of my lamps. Cant use it with automation anymore and i am getting the same “abnormal error”. I could use it through the yeelight or mi home app but not with automation anymore.
I have many lamps around the house so after struggling with that for 2 days, i had to exchange the lamp with a less important one (now it is acting like a dummy lamp)

I realy don’t have an idea how to solve this. Even a brand new yeelight led-strip which was never connected before has this problem with an automation.

I hope one of the yeelight persons can take a look into this matter. @weiwei maybe?

Well this is an interesting discovery: i made a personal hotspot with my phone with the same Ssid and password as my router so my yeelights and gateway will connect to my phone. Then I tried to run the automation and quess what: it worked!! The yeelight was going on and off.

So the problem is somewhere in the routersettings I quess.
This brings us already a step further. Keep you posted

Yessss! I found it!! Cool, automation is working again!
I had to go in the settings of my router (i have a fritzbox 7490).
I had to go to the ‘wireless’ section, then to ‘securaty’ and the enable the option ‘The active wireless devices displayed below may communicate with each other’

And voila, it’s working!

I hope it will work for you too. Good luck!

i dont think that this is the problem for me since the rest (7) lamps are working and only one has this problem (works as standalone and through app but not through automation). If it was about router settings then all 8 lamps would have the same problem. Glad it worked for you and you solved it.

1 Like

Hello folks,

I am a proud owner of 3 Yeelights E27 bulbs, set up with one gateway and one Mija switch. My entire system had been working like a charm for months.

However, since today evening and following a reboot of my DSL-router, I am experiencing the same problem as you. One of my Yeelight E27 bulb is not responding to my automation scene when I click on the switch, whereas the two other Yeelight bulbs are perfectly working and responding to scenes.

I also checked logs in Mi Home application (Automation tab > Logs) and I discovered an error message : the scene in question “Couldn’t run” and by expanding the scene details, I could see a generic error message for the Yeelight E27 “Abnormal Error.”

As of now, I tried to fix this problem by doing the following steps :

  • resetting the bulb (5x switching on/off) and synchronizing it again with the gateway ;
  • deleting the scene and recreating a new one.

However, this did not solve the issue. I am still having a Yeelight bulb that does not work with scene automation but which can be fully controlled from Mi Home or Yeelight application on my phone. This is extremely strange.

I read that you hopefully found a way through your router settings however i don’t have such an option in my case. And I think it does not help to understand the problem as only one Yeelight bulb is concerned among several ones.

This issue remains to be cleared and any comments will be useful.

You can try to make also a personal hotspot with your phone (and put-in the exact same ssid as your router and use your routers WiFi password for your personal hotspot too) so the gateway and yeelight Will connect to your phone automatically. Then try again if the automation is working. If yes, you have to search for a solution inside the router settings.

The problem started also suddenly for me and I didn’t change anything in my router before. It’s worth trying eventhough it is strange that only one bulb is acting weird. Just give it a try.

Resetting the bulb and deleting the scène didn’t gave me the solution either.

I followed your advice and I tried with a my phone as Wifi hotspot with the same SSID/password as my regular DSL routeur. And like for you, my Xiaomi Yeelight scenes worked perfectly for all bulbs, as it was working before.

This remains however weird. As I do not have a FritzBox, I tried to figure out what does the option on your routeur consist of (i.e. to see whether it exists on my own router but under another option/wording). Unfortunately, the routeur provided by ISP does not over so many settings.

So I tried another things, which has fixed the issue so far : I set permanent IP for each of the Yeelight Bulb. I looked for each bulb MAC Address and I configured my router to have permanent IP address for these bulbs, outside the DHCP range.

And, voilà ! I restarted both the bulbs and the router and everything is working perfectly fine for now. I cannot confirm if this will last but it is working fine now. It reminded me many trouble with a SAMSUNG wireless printer which was perfectly for some time and thereafter I could not print. Further to a call with Samsung Service, the technician recommended me to use permanent IP address (configured through permanent IP lease on the printer’s MAC address on the router) and this successfully solved the problem.

I think this problem is related to internal routing and security and perhaps to NAT/firewall requirements, since this is perfectly working from a mobile android hotspot (which does not feature NAT/firewall or advanced routing settings). But I am not a network/IT engineer.

Good luck and I will keep you posted regarding any change!

Expert or not, you mentioned it to get it working again :slight_smile:
That’s nice!
My scenes are also still working so I’m still happy.
Glad that it’s working for you too!

Party the same problem here.
Al IP’s are fixed

But de wireless switch won’t activate my yeelights and Mi smart socket(wifi).
De switch works fine with the gateway (detects clicks and can switch the gateway light etc)

The yeelights working fine with the smoke detector automation(light going on when smoke is detected)
And the yeelight geofencing works fine too (switching the light on when comming home.

But the switch with the lights i get an “error” in the automation log.

Any idee?

I had the same problem. My router restarted. My sitches could not control the bulbs any more but i could control them via app.
SOLUTION: deactivate IPv6 in the config of the router.