Lightstrip not connecting wifi to Singapore server

I’ve been trying to connect to the Singapore server because it said the IFTTT only works with when connecting to Singapore.
I’ve did successfully connect to China server BUT my IFTTT didn’t work and didn’t recognize my lightstrip.
I’ve tried resetting it 5 times on/off and I’ve tried different combinations :
-log off, get out of app, reset, connect to yeelight wifi, then back to my wifi, then open app and log in my wifi then yeelight wifi and it just stalls and gives me a red "x

  • log on, get out of app, reset, open app, connect to yeelight wifi then stalls and gives me a red “x”
    Etc etc.
    can someone help me? I just want to use the ITFFF with my Alexa
1 Like

To reset the lightstrip, you need to unplug the power adapter, hold the button and meanwhile plug the power adapter, keep holding the button for 5 seconds until you see the red/green/blue flows.

Yes, I did that 5 times and it still does not connect.
I have tried if on different days

Could you see the AP started by the light strip (named yeelink-light-strip1xxxx) ?

Yes, I see yeelink-light-strip1xxxx and I can connect to it. once I do I go back to the app it looks like it’s connecting and gives me 25% and then never connects fully. I then get a red “X”. Shown in the picture

1 Like

1、Could you please check whether the device is in the router’s device list?
2、You can try Mijia App.https://itunes.apple.com/cn/app/米家-精品商城-智能生活/id957323480?mt=8

Are you connecting to a 2.4ghz wifi?
Not sure about the light strip but I know the other yeelight products don’t support 5ghz.