Lightstrip connection failed

Been trying to add a new device (Lightstrip) and it would continuously fail. Managed to setup a few bulbs with breeze. Trying to connect the led strip to the same wifi network. Its clear that the wifi setup works but unsure as to why the strip won’t connect! Have reset it countless times now, and tried to connect via different wifi network and cellular hotspot too, no luck. Tried to set it up from both iOS and Android device. Most of the time, the blinking orange led would turn to a constant blue while the setup is stuck at 25% post which it fails. I see the device while running a network scan, could ping it too.

Tried to set it up via Mi Home as well but same issue. I have tried connecting to different cloud servers as well. Request the staff to check on their end.

Network scan and ping results:

Could you see the device in your router’s DHCP list after the connection failed?

And could you post the ping result of "”、"”、” and”?


Can I reach you by wechat or whatsapp? We need more information to debug this issue.

Ping results for different servers:

Looks your network is good to Singapore server. Could you please try again with SG server again? If you get connection error again, please PM your xiaomi id to me.

im having the exact same issue with the lightstrip

I have been having the same issue. No matter how hard I try or whichever application. Please help.


@all adsafs

  1. Please refer to:
  1. Please double check if there is any character other than letters or numbers in your network SSID and password.

Hi all,

Experiencing the same issue (“Connection failed”), previously it was working but since I’ve changed my phone and was trying to setup it with the new one, all the time get this error.

Так как решать эту проблему? 25 % и ошибка.