Lan control issues

Can someone explain me why the lights are not responsive when trying to controll via lan and not internet? For example i am trying to control them with tasker and 90% of the time they dont listen to the task. I have tried 2 different android phones and 2 different routers but no difference! If i try to control with google home or assistant it works much faster and always do what i want to do. Someone please answer because i want to embed them in tasker

i don’t think that this is the case. dalanik’s addon for kodi works via lan and the commands work pretty well. maybe it’s your wifi connection or tasker?

by the way, can you share the idea of using tasker? i have not found a scenario yet where i need tasker to control my yeelights (having in mind that i use the xiaomi gateway)

well yeelight toolbox (which changes the color by whats on the screen) works fine for me. It’s just like after some inactive time it stops listening unless i spam the command…The idea i had was that when my phone sees the computer’s bluetooth in range, toggle the lights on. When it is not in range toggle the lights off. I also have some other brands smartplug and i have created a tasker shortcut that when i press it it toggles both of them. One more is that when i tap the NFC tag i have it toggles them too. I mean the ideas are infinite

in my case i have an access point with a unique broadcast ssid. so i use IFTTT to turn on a d-link smart plug when i enter the room.

personally after testing i decided that there is no need to have such complex apps and scenarios and blah blah blah. just get the xiaomi 5 in 1 set and you are done. it has a motion sensor so there is no need for the bluetooth thing. it has a wireless button so there is no need for the nfc tags and your mobile phone.

I want to buy the set soon. So you have the sensor right? Is it working right? Can you make them so they shut off if inactive for x time?

the motion sensor is amazing. can check motion up to 7 meters (tested) and you can set the inactive thing for up to 30 mins

thanks for your answers!

You are useing Yeelight from Tasker? That is the same as using Yeelight. It just fails on LAN control sometimes. I rote about this, let’s hope they fixed it in v3.0 that come out today.

If you REALLY an to use LAN control, use Tasker with Send/Expect plugin. It never fails and works instantly (almost everytime) :slight_smile:

I’ll try it. But where can i found the commands needed to send for the lights to turn on/off? Is THAT it?

Well i just tried it and the results was the same…I think the only better way i can improve the accuracy is by buying the gateway…Anyway thank you!

Yes. Hmm, that is strange. No way gateway will improve anything… it is just another device in chain which can only slow things down…

Here is the demo of Tasker/Send-Expect combo… it can’t be the same as Yeelight app, much faster…

It seems to work great with you. You know thats the case with me also but only when i have opened the yeelight app and wait for 2 minutes to load all the aspects. Nice video!