Issue with Mi Bedside Lamp wi-fi after latest firmware update


#1

I have two Mi Bedside Lamps wi-fi. Yeelight app informed on new firmware 1.5.5_0166. I tapped to update on both lamps, during the update lamps automatically turned off and on but the update status indicator was still at 0%, after a while it said that an error occurred. Lamps stayed on but the connection with the Yeelight app was lost with the lamps status offline. I turned lamps off, made a reset and tried to connect to the app but no result. I tried everything, changed servers, changed languages, installed Mi Home app - no result. Lamps are working when I use the button, are seen by the app on the initial stage of scanning but the final connection fails.

How to solve this issue? Please advise.


#2

Found the solution here:


#3

Should I still need a new firmware? In this case my Mi account ID is 4150698078.


#4

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

And next time when you encounter the issue, please don’t try to reset the device at the first time. You can have a try do a power outage of the lamp wait for a minute to see if the lamp back online again.