How to Firmware Upgrade?


#1

I recently got a the yeelight床头灯 (bedside lamp) up and running with little effort. However i can’t seem to upgrade it’s firmware, or at least i don’t know how. Can someone please provide instructions on how to upgrade the firmware? I’m running 2.2.02 and i know there is newer firmware. Without it i can’t use all the features of this lamp.

Since the connection method is bluetooth instead of Wifi, i assume the process is different. For the Wifi devices such as the bulb, i had no problem upgrading firmware. In the menu of the Wifi devices i have the ability to “click” the firmware version to upgrade. However for the bedside lamp the firmware field doesn’t appear to be a “clickable” button.


#2

Suppose the firmware will be upgraded automatically during the connection. If the upgrade never happen, please double check if your phone could access internet to download firmware image, and if your app was granted the permission to access storage of your phone.


#3

Thanks, but unfortunately it does not seems to be the problem. I confirmed that the apps has all of it’s permissions and i was on Wifi (i also have a mobile connection as well).

If this should be an automatic process, at which point is the firmware version checked and determined if an upgrade is needed? During the startup of the app? Does it routinely check in the background? Is there any way for me to recognize if the image was even downloaded in my phone storage (maybe i can check a specific directory)?

Is there an official yeelight app for windows? I’ve only been trying with an android device. I did come across some other post of someone also having difficulty upgrading via android.


#4

I just realized that when the Bluetooth connection is made, one of the four bullet points is a firmware check and it passes with a green checkmark. SO the app thinks i am running the latest firmware (maybe 2.2.02 is the latest?). However there appear to be a few features such as the “wake up light” and “sleep timer” that appear to require the latest firmware. When i try clicking these, it says i need a firmware upgrade.

Can you please tell me what the latest firmware version should be as of 9/18/2017.


#5

Any chance to try with another phone?


#6

I did actually. I have a Google Pixel phone myself that i was using and then i tried with a xiaomi phone. I assume it shouldn’t matter which server i am using, but i’m currently connected to the china mainland server instead of Singapore. I did try switching over to the Singapore server, but then i couldn’t even pair with the lamp. i’ll try again later.


#7

So I tried again on the Singapore server without success. During the connection process when the firmware is checked it still passes through with a green check mark as if it thinks the firmware is up to date.

Could this be because my phone has not fetched the latest firmware image?
What is the latest version?
Is there any way I can check to see if my phone has downloaded the latest firmware?
How is the firmware downloaded through the yeelight server?
Do I need to open a port on my router?


#8

Same problem here…No way to upgrade its firmware