Google Home not responding

Perhaps this is a question for google, but I’m hoping it’s not.

So I bought a colored bulb yesterday and it’s wonderful. I linked up and it works fine on the app. Then when I go to my google home app I link up the yeelight and make a room and it’s says everything is fine. However when I command google to turn of the lights it says it can’t find the lights…what am I missing?

And I’ve tried linking and unlinking.

Check to connect to Singapore or U.S. servers? Don’t connect to China server!
If not, please tell me your xiaomi ID.

I am connected to Singapore, I do not see U.S. Even thou I live in U.S

My ID number is 1736718750

Try to rename your device to “Color Bulb”, Then say “Okay google, turn on Color bulb", see if it works.
I view the logs from the backend.

No still no luck

I didn’t find the Google-Home’s callback information in the background, only you use your phone’s sync device’s log.
Check to see if your google-home is connected to the Internet or reset your google-home and re-connect.

I’m connected to the same wifi and still no luck. I reset my home and still nothing either

What’s the google home response?

Except google home, you can use Android 6.0+ mobile phone.

I am facing same issue:(

Say ‘turn on [bulb name]’ not response?

So I exchanged the light bulb and the new light bulb doesn’t work either. So I called google and after a few troubleshooting steps I was informed that the yeelight isn’t still compatible with the google home.

So I had to set up through IFTTT, which works fine

I found your device name is ‘Yeelight Color Bulb’, it is possible that there is no word yeelight in English, so it isn’t callback.
Please try to say “Okay Google, turn on all lights”.

There are two things come to my mind:

  • Reboot your Google home device.
  • Try creating a hotspot on your phone instead of using the wifi network.

If you still facing the problem, try these more solution to fix the Google home not responding problem.

When your Google home accessories and speaker doesn’t respond to your commands then I would suggest you to do some troubleshooting steps such as Reboot Google Home, Check that Google Home recognizes the OK Google, Check Internet Connection. If everything is perfect then restart your Google Home. I also did the same thing and got my problem solved.

Hope it works for you as well.

Google home makes your life simple by its function of speaker, your routine task manager, appointment reminder etc. if you’ve facing issues, you need to first of all unplug the Google home for 1-2 min and plug it again. Make sure phone or tablet connected with same wifi as your Google home or home mini.

Reboot Google home

Google home app > Device under Home tab > Settings gear icon upper right corner > device settings > More (Three vertical dots) > Reboot

If none of the methods fix issues, you need to factory reset Google home or home mini.