Google Home and Google Assistant won't add Yeelight Actions


First post here and unfortunately it’s because I can’t get the yeelight actions to link up with google. I seem to have the same issue as a few others in that when I try to add the device to google using the Yeelight Actions I get prompted for my yeelight account which I enter and then hit sign-in and it either hangs with a blank screen or returns the "give this app the following 2 permissions.

I’ve tried resetting my phone to factory settings(this was painful)
I set the server as Singapore
The bulbs are named uniquely (1 x white, 2 x RGB)
I’ve tried creating a fresh Yeelight account
I’ve tried creating a fresh google account
I tried setting my phones defualt browser to chrome but when I do that the “sign in to yeelight with Mi Account” page just loops

None of the above seems to work and any help would be appreciated please…Yeelight ID 1594175255

Ignore my previous post it just started working, if anyone needs any info on the above let me know. Thanks

Hi, same issue here, just cannot get it to see my bulb. Any advice?

Hi, I’m not sure I can tell you how to fix it but I can tell you the steps I took before it worked. I renamed the bulbs using the yeelight app from the default names. I then set google chrome as my default browser on my phone, I thought it was already set but it appeared that there wasn’t a default browser at all…which seemed odd. The next bit which I think might of been the solution was I opened the chrome browser and went to and logged in. I then opened the google assistant/google home app(can’t remember which one) and tried to add the yeelight actions. This time it just worked and added the bulbs.

The odd thing with all of this I tried to add the yeelight actions to my wife’s phone and it worked straight away which is why I tried factory resetting my phone.

Let me know if the above works for you