Default state is not working as expected


#1

First of all, it’s not clear (to me) the difference between automatic State Recovery and Custom State is, and why you can’t use one without the other (If you select one, the other is greyed out.)

My rationale is that I want to have to set a default brightness, in other words I want to define how bright the light should be when I manually turn it on.

I’m also using the sunrise scene in the morning, and Yeelight app thinks the default brightness is the last state (100%) when I turn it on manually. But if I turn it on manually I want it set to my predefined default state, not the last state.

I think the default state should be independent of any scenes. Does that make sense?


#2

I think “Use Custom State” can fit your requirement, which the device will turn on with the light your set from the power source. However, the light can not be a Flow mode scene, such Sunrise and Sunset, it can be a color with a brightness.

And, we received lots of feedback that the bulb will be turn on after power outage (As you know, there are lots of places with unstable power may case power outage), so we did the feature of “Automatic State Recovery”, which will let the device keep state of last state(including OFF state). But you can not use an “OFF” state to “Use Custom State”.


#3

I have tried both, including custom state, and it always reverts to 100% even when I had set it to 10%.


#4

Seems this is a network issue. If you set “Use Custom State”, it saves current status of the device. So please dim the device, and see from main page to see if the state of the device state calls back or not. If yes, please set “Use Custom state” again.


#5

Thanks, I’ve been trying to set “use custom state”, but I always get a “save failed” error, although I’m able to control the light from the app (on/off, change brightness, etc).


#6

When will this function be available for the led strip??


#7

@dingyichen I was finally able to get “Use Custom State” to save (after various tries and different times of the day…). But it’s still not working as I expected (see above). Here’s what is happening:

  1. I set brightness to low and saved “Use Custom State”. I tested it and it works.
  2. In the morning I have a scheduled sunrise scene set with my alarm, and no problem.
  3. I have another schedule to shut off the light.
  4. When I manually turn on the light, it doesn’t use the “Custom State” I set, but it’s at 100% (which I suspect is because of the sunrise scene).

#8

I got your point. It seems there is no problem with “Use custom State”, it only works by turn on the light from the switch not from the application.

Do you turn on the light by the app? The light will recovery from last state instead of light set by “Use Custom State.”


#9

Sorry I wasn’t clear. Yes, I’m using the app to turn on the light. I’m expecting that behavior, and I would think it would be the same, whether I turn on from the app or from the switch, right?

Maybe the simplest solution is to have an option in the app to save a default brightness when the light is turned on from the app. I imagine others would appreciate that when you turn it on from the app it’s not at 100 automatically and then every time you have to set it less bright. What do you think?


#10

It makes no scenes that every time you turn it on at 100 brightness, it turn on with LAST STATE (brightness of white bulb, color and brightness of color bulb). We will not change the behavior of that. Cause you schedule a sunrise scene in the morning, the light will on with 100 brightness when the scene runs completely in 15 mins. That’s why turn the light on at 100%.

From your case, if you want turn it on some brightness, you can add a new schedule after Step 2 with some brightness you want.


#11

It makes no scenes that every time you turn it on at 100 brightness, it turn on with LAST STATE (brightness of white bulb, color and brightness of color bulb).

I’m not sure I understand what you’re saying (sorry).

My reasoning is that a “scene action” is currently independent from the simple on/off action - it doesn’t consider the last state of the manual brightness I set; and the on/off action should also be independent of the scene action, otherwise having a “custom state” option is useless for users who have scheduled scenes, understand?

When you turn on a scene it does not consider the LAST STATE, but the on/off considers the last state of the last scene. That’s silly. Manual on/off should use the custom state I predefined, not the last state of a scene. I’m not sure what the custom state is useful for if users have set up scene schedules. Again, this is one user’s opinion.

If I understand your suggestion, you say, after my scheduled sunrise scene, create a new schedule with the desired brightness? so at that point (say at 10:00am) I would turn on the light. And then create another schedule at 10:01am to turn off the light, just so it remembers the state I want it to turn on default when I manually turn on the light at night? Wouldn’t that mean the light will be uselessly on for a minute? Dunno, if I understood what you meant.

Sorry if I need more help understanding this, and thanks for your patience.


#12

Hello how did you solve this problem?? I have same problem :confused:


#13

Hello, I have the same issue vevola is describint with my new Mijia Bedside Lamp.

Eventhough I set a custom color as default, when I turn the lamp on it remembers the last state always. so that functionality is not working properly at all.

It should not matter if you turn it on manually from the physical button on the lamp or from the virtual button on the app, that is pretty basic expected behavior.

I updated the firmware and still this is not working.
Any news about this?


#14

I think I have a simialar problem.

I have set the default light for my lights to have a certain color and a certain intensity.
If I turn them off and back on using the physical switch - they turn on with my setting corretly.

However - If i play with them, have fun with guests and change color and then turn them off with the app, when I turn them back on I would expect them to be returning to the default. It’s logical. That’s what default is for. There should be at least an option to choose whether you want it to revert to the default setting when restarted with the app.


#15

It doesn’t make any sense to set a default state when you turn on the light with app. If we take it that way as you said, there will be more user ask: why the lamp lost all settings after it was turn off?

As you were using the app to turn on the lamp, if you really like some kind of default state in that case, you can either add that state into your favorite or your scene list. You can simply restore your lamp to that state.


#16

It wouldn’t make sense for users that only plan to use the yeelight with the app, you are right. But it makes sense for users that plan to use it with another smart device, like google home speaker. There is no obvious way to set the lights back to ‘default’ with google voice assistant and for some of us the whole point of purchasing yeelight lightbulbs is to be able to control them with voice and the app serves as secondary option.

I think having a switch somewhere in the settings that allows you to choose whether or not your lamp ‘forgets’ the settings when turned off with the app could server a broader audience and be beneficial for how the product is perceived.


#17

Actually there is. Just as I said, add a scene with the Default State your want, then sync Yeelight with your google home again, you will find the scene in Google Home app.

Say “activate + scene name” will work.


#18

I found this option and yes - it works. But I wouldn’t call it ‘obvious’ but rather an operational wrokaround for users that want to dig into the internet and find that option (which, by the way, works only if you remember to unlink and re-link the yeelight account to google every time you create a new scene). Creating an option in the firmware would be a nice gesture towards the perhaps less tech-savvy users.


#19

No, you don’t need to unlink and re-link. Just say “ok google, sync my devices”.