"Connection timeout" problem

Hello yeelight!
Finally I got your colour bulb, but feel so saddened about this frequent connection problem I have.
Here’s the deal: I am now currently living in a polar russian town Barentsburg, located on norwegian island Spitsbergen. I have almost no problems with connecting the bulb at my workplace, but whenever I’m trying to use it at home, the process of pairing freezes at 45%, and then percents are continuing to count (till 80-90 something), but nothing happens, and in the end I’m getting this “connection timeout” screen.
So, the router model I’ve got at home is Upvel ur-326n4g - I was already trying to do something with dns or to change my location to Singapore, but it seems like it’s not too helpful. May be I should do something special about router settings?
And my mi-id is 1666065379.
Any ideas?

We got some the same issue with you, could you try to set DNS on router to, reset the bulb and try again.

After your connection failed, please logon to your router and check if the bulb has connected to your router. If yes, then it has something to do with the cloud, otherwise, we need to take a deeper look at your router’s settings.

I’ve already tried to set as a dns on router, but it makes no result(
But I’ve just asked a sys. admin of the town about possible reasons of this trouble, and he said that it may be something with port. Can you please tell me, which port uses yeelight bulb to connect? Thanks.

Could you try:

  1. Check your bulb can be seen in the router.
  2. Ping “ot.io.mi.com” to see if it’s reachable.

So, yes - it’s connecting to the router (at least, it tries to reach it, because I can see yeelight in dhcp-clients list), and it pings ok to “ot.io.mi.com”. What else could we do?
Could you please tell me the port bulb connects to - 1982, or something else? Because I think it could cause a problem, if this exact port is blocked by sys.admin.

The cloud is listening on port 8053 for UDP and 80 for TCP. Please check with your ISP.