Connecting problems

I’m having a problem with one of my Colour bulbs. Two work perfectly, but one took many tries to set it up and connected to wifi. I eventually got it connected.
I experienced a power cut and although the other 2 reconnected ok the third one is offline again. I’ve tried to get it to reconnect but no luck. I can find it on wifi ok (in iOS settings) but when it tries to initialise, it fails. I try it again and it’s wifi can’t be found and I need to reset it and try again. I’ve tried connecting it using both the Yeelight & Mi apps, but it keeps failing. Help! Any suggestions? :worried:

Could you see the bulb in your DHCP list?

Is signal strength good for the bulb that doesn’t work?

Yes the 3 bulbs are all within approx 4m of the router. Since the power came back on the other 2 work well but this one is showing in the list as offline. I’ve hit refresh but it just says to reset it. I have but it goes through the process and in the Yeelight App it sticks showing “Connecting 25%” and fails each time. In the Mi app it goes through to 100% but then says to reset.

The offline bulb is the one take you many tries to setup in the first place, isn’t it?

Yes it took 4 or 5 goes to set up the first time. But I got it to connect using the Mi app then used it in the Yeelight app.

Same problem
I didn’t have any problem with 17 bulbs but one of them do exactly the same
@JulsMartin : Hi
Are they in the same shade (chandelier) ? With one main power cable ?

No. They are each in separate lamps. So, did you get the problem 18th bulb working? How’d you manage to get it to connect?

Do you mean that bulb will lost connection after power cut, when the other 16 bulbs get no problem?

How many times you have experienced?

Yes, you must power cut The bulb 5 times to reset and I found a way ! I removed the physical key so there is no powercut any more

Yes other 17 bulbs has no problem
This one is the one that I tried 3-4 times to connect it to wifi, “freeze at 25%”
This happens 3 times for me and then I removed physicall key and there is no powercut anymore ( reason! Everytime I reset that bulb all schedules erased )

What do you mean “physical key”?

And, you have never setup the bulb successfully, right?

Yes I got mine set up after 4 or 5 tries initially (a week ago) but now I’ve tried resetting it (switching off & on 5 times,) then trying to reconnect to wifi about 10 times and no luck. :frowning:

Yea- "removed physical key’??? :hushed: