Can't turn music mode on?

I am using telnet to connect to the color bulb or led strip. if I send command to turn it on, change color etc, everything works. But if I send command to activate music mode, it reports error… i.e.:

{“id”: 1,“method”:“set_music”,“params”:[1, “”, 54321]}
{“id”:1, “error”:{“code”:-5000,“message”:“general error”}}

Any clues?

Bump, any ideas? It used to work… Now it doesn’t work at all not only on the bulb that I am using but on LED strip as well, always same error…

Is there a TCP server listening on

Yes, ofcourse, there is. It used to work (not always, but sometimes) and all of a sudden it just stopped and I am constantly getting general error. Even on LED strip which I never tried to set into music mode before. When I run server I can connect to it with telnet on port.

Here is the video demo of me running server and of error;

*I am connecting to the bulb via telnet and it is responding to commands
*I am running server and deonstrating error when trying to set bulb in music mode
*I am connecting to the server from telnet and receiving commands from server (the server is working!)

Could you use command “get_prop” to check the “music_on” property of the bulb? If the bulb thought the music mode is already on, it will reject the turn on command.
Also, you can try to close the music mode and then turn on.

Hmm, good idea, will try. It didn’t occur to me to try since the bulbs are responding to “normal” commands and I thought they can’t be in music mode.

Yes, that seems to be it!!! So I have to check with get_prop and then turn the music mode!! Thanx!