Can't integrate with Google Assistant


#1

Hey,
I have set up the lamp with the Yeelight app. I can control the lamp from Yeelight app. I linked my google account with my Mi account, so I could use Google assistant to turn on and off the lamp. The link was successful, but every time I try to control the lamp with my voice, Assistant says “It looks like the Mi LED Desk Lamp isn’t available right now” or “Encountered an unknown error for the Mi LED Desk Lamp”.
It is connected to WiFi, I double-checked everything, but it doesn’t work. I tried changing servers from Mainland China to Singapore and more, with no success.

Do you have an idea why it happens?

Xiaomi MI ID: 1741558076


#2

Google Assistant calls the lamp Desk Lamp and not Mi LED Desk Lamp becuase I have renamed it. I thought renaming will help this issue, but nothing has changed.


#3

Could you try to relink mi account with goole Assistant and try again?


#4

I’ll try, Which server should I use?
I tried both mainland china and Singapore.


#5

I also have a Wifi Amplifer 2. I don’t know which server should I use, and which app… Everything causes such a mess. Can you help me please?


#6

Since i change to china mainland stopped work for me. When in US server was ok


#7

Google and Alexa support are only available for servers except China Mainland. So you can select Singapore or Us server.

You can try with Yeelight application to connect you lamp. You can refer to https://thirdparty.yeelight.com/page/app/google-home/link.html?VER=20171128


#8

The problem is that if I use Singapore/US server, I can’t have my Wifi Amplifier 2 in the Mi Home app… I can find it in the products list only on Mainland China.


#9

Due to local laws and regulations, Google are only available for servers except China Mainland. Sorry for the inconvenience.


#10

So which server should I use if I want both my LED lamp and my Wi-Fi repeater to work?


#11

China Mainland, but you can not use Google Home.

Do you have any special with your Wifi Amplifier? I suggest you can connect it to ChinaMainland, and connect the lamp to Singapore/US server.